User interface not started after Safe Anywhere Mac installation on OS X El Capitan

F-Secure Product Expert

User interface not started after Safe Anywhere Mac installation on OS X El Capitan

We have noticed that our product user interface does not launch automatically after installation on OS X El Capitan.

Everything works fine if you launch the product manually from the installation folder, and also after a restart the product starts up normally.

The good news is that OS X upgrade scenarios are not affected. If a user has our product installed and does an OS X upgrade, everything works fine and the product works as intended after the upgrade. Only new installations on OS X El Capitan are affected.

We are investigating the issue and we will keep you updated as soon as we know the timeframe for the fix.

As a workaround you can restart the computer after the installation, or start the program manually from the installation folder.

Affected products are Anti-Virus for Mac, Safe Anywhere Mac and PSB Mac Protection.

Best Regards,
Jouni

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
5 REPLIES 5
Superuser

Re: User interface not started after Safe Anywhere Mac installation on OS X El Capitan

Hello,

 

Is there a status update?

 

Best regards: Tamas Feher, Hungary.

Scholar

Re: User interface not started after Safe Anywhere Mac installation on OS X El Capitan

But it is still not possible to enter your product key in system preferences due to the new root protection in 10.11
F-Secure Product Expert

Re: User interface not started after Safe Anywhere Mac installation on OS X El Capitan

Hi all,

 

This problem will be fixed in the upcoming release. However, the exact release date is not yet available.

 

@Wildestpixel: That should not have effect on our product. In this case I would recommend opening a support ticket and providing fsdiag diagnostic file for further investigation.

 

You can open support request here:

https://www.f-secure.com/en/web/home_global/support/support-request

Best Regards,
Jouni

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Scholar

Re: User interface not started after Safe Anywhere Mac installation on OS X El Capitan

Sorry already moved to another provider supporting the current OS - my subscription to F-Secure is melting away whilst you fix the issue.

 

I already opened a support ticket and can't / won't provide FSDIAG output as I don't wish to install Xcode to do so.

 

I'm not your beta tester, I'm a user with a subscription. It should just work on the OS provided by Apple for my machine.

 

If I cannot enter my serial number I cannot use the product and my subscription vanishes day by day. If it were a free AV product like Sophos I could accept this. 

 

I imagine this response will get deleted.

Highlighted
F-Secure Product Expert

Re: User interface not started after Safe Anywhere Mac installation on OS X El Capitan

Hi all,

 

We have released the new version 15.4 build 15629 available, which is officially supporting Mac OSX El Capitan, and it should also fix the problem with the user interface problem.

 

@Wildestpixel If you are still willing to try, please try whether the problem is still there with the latest version. Regarding the fsdiag, even though it is notifying about Xcode, the logs should be collected regardless of Xcode being installed.

Best Regards,
Jouni

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.