F-Secure SAFE (Windows 10) problem with Git for Windows

Highlighted
dkt
Novice

F-Secure SAFE (Windows 10) problem with Git for Windows

I started having a problem today with Git for Windows, everytime git was invoked it would hang for about 2 seconds, quite problematic when also using git bash as the prompt generation runs a git command causing it to take 2 seconds to return the prompt after every interaction with the shell.

 

There were some F-Secure updates applied this morning, Git for Windows has not been updated, the last windows updates were 3 days ago, and this was not a problem yesterday.

 

Disabling F-Secure SAFE resulted in git command responses of 28ms and everything performing as normal.

 

Having F-Secure SAFE enabled but excluding the c:\program files\git directory from Deepguard resulted in git command responses of 28ms and everything performing as normal.

 

Running other commands from a command line results in an approximately 2 second delay on the first run, but, subsequent runs appear to be at normal speed. e.g. ping, nslookup, php, all affected on the first run only when F-Secure SAFE is active.

1 REPLY 1
Superuser

Re: F-Secure SAFE (Windows 10) problem with Git for Windows

Hello,

 

I am only an F-Secure user.

 

Perhaps, you should to contact their official Support channel (web-chat, for example):

And before that - to create fsdiag after repeating the trouble:

At least, it can be much more useful than trying to find one reason from multiple potential ones.

You could also try to check updates and restart system then (what if the trouble is already fixed).

 

Thanks!