Many sites block by FS+protection

FS protection blocks access to known absolutely safe sites. In particular, access to Wikipedia, to US universities sites is blocked.
What should I fix in the settings?

Answers

  • UkkoUkko Posts: 2,895

    Hello,

     

    With my experience there can be normal access to some of known websites.

     

    But what kind of "blocks" you mean? Does there visible Block-page (if not - do you able to switch from HTTPS to HTTP under address bar?) with reasons like "Harmful"-page, "Suspicious"-page or "Restricted"-content?

     

    If there wrong harmful rating for safe website -> most helpful step is F-Secure SAS: https://www.f-secure.com/en/web/labs_global/submit-a-sample#sample-url 

     

    If there restricted content (as Family Rules Content Blocker for some categories) - you able to switch off current feature under My FS Protection Portal (or re-change restricted categories);

     

    But... as example, do you able to open this URL:

    https://no.wikipedia.org/wiki/F-Secure

    ?

    With my experience this wikipedia article normally opened. I have experience when some of articles can be marked as specific "categories" (which restricted by Content Blocker); or when most likely safe-page marked as suspicious/harmful;

     

    Or do you mean that you have experience with blocking access during Banking protection session (where visible "flyer" as activated-status)?

     

    If there something not common - most likely - good to report about it (such as - if you have experience that certain safe pages unexpected blocked).

     

    Sorry for my reply!

     

    Thanks.

  • Thank you, Ukko!

     

    I will try to follow all your advice and write again.

     

    As a rule I get the message "Harmful web site blocked", and the option "Allow web site" does not work.

    So, now I have to first disable the FS protection, and only after that I can restore contact with my phone call provider and with many other reliable sites.

     

    For example, even the page
    https://community.f-secure.com/t5/Home-Security/Competitive-site-blocked-where/m-p/93700?lightbox-message-images-93490=5888iE13810DBA1FBD3A7#M3451
    is blocked now (!!!)

     

    Leonid

  • yeoldfartyeoldfart Posts: 506

    I must admit I have permanently disabled this feature as it is too much of a pia... Sorry fot this.

  • UkkoUkko Posts: 2,895

    Hello,

     

    I see.

     

    What about option "Allow web site" - there was official response from F-Secure team under topic about it:  https://community.f-secure.com/t5/Home-Security/There-should-be-quick-fix-for/td-p/93529

     

    And for my understanding - "option/button" will allow web site (as "adding it to allow list of websites), but just list of allow/deny websites do not work (ignoring by FS Protection). And as it was with F-Secure response - it not known when it will be fixed.

     

    I also have experience about current situation, when I have to  disable "all security features FS Protection" (as most brief step to get access), but for me it about "restricted content" (usually "unrated/unknown content" category).

     

    With harmful-rated webpages - I think that most good step is transferring URL to F-Secure SAS.

    For re-rate it or for get explanation (if there indeed something malicious).

     

    But with my experience: URL/situation - which you noted as currently blocked... - allowed to me. And I able to see "safe"-rating (by F-Secure) for URL under search engines. So, maybe will be good to create ticket/report about it. Or will get official response from FS Protection team with workdays (maybe there required something as ORSP-cleaning - but with my experience it may be required some of fresh steps to do so).

     

    Sorry for my long reply.

     

    Thanks.

     

     

  • Thank you, Ukko!
    I'll try to do it.


    However, all this is rather  strange: like the fact that for a long time FS protection did not block those sites that are blocked now at my comp, and the fact that, as you write, the program has some important shortcomings.

     

    Yours

     

    Leonid

  • VilleVille Posts: 477

    Hi,

     

    There are two issues here.

     

    1. The 'Allow web site' button is broken. This is due to the changes we are doing with the beta product and will be fixed (quite soon).

    2. Incorrect categorization of safe websites. This is a problem in our categorization system and in order to fix it, I ask you to submit always a falsely categorized website to here: https://www.f-secure.com/en/web/labs_global/submit-a-sample#sample-url

     

    Ville

    (F-Secure R&D)

     

  • F-secure13F-secure13 Posts: 6

    Dear Ville,

     

    Like many users of FS-protection beta, I have to completely disable all protection during each day. There is no other way to enter many necessary and absolutely safe sites.


    When can we expect that the program will be fixed?


    There are at least three such defects:

    (1) the permission button to enter the site does not work at all;

    (2) lists of allowed sites do not work;

    (3) the internal classification of sites does not work well for permissible and unacceptable.

  • UkkoUkko Posts: 2,895

    Hello,

     

    Sorry for my reply.

     

    But with latest recent TP update (TP190) -> https://community.f-secure.com/t5/Home-Security/FS-Protection-PC-Release-190/td-p/94039

     

    At least first two points should be fixed already.

     

    With TP190 - my Windows 10 system with normal status for 'allow-website' button and 'lists of allow/deny websites';

     

    But if there will be crash (?!) - it possible that such points will be still there (for me workaround is perform restart system or FS Protection services); But it should not be there;

     

    With third point- I'm not sure that I able to think about this things properly (because, looks like that such design was there already long time), but (something as fresh trouble) there can be funny detection for any website as harmful-rated (temporary) - if there will be broken/trouble/disabled network-connection.

     

    Sorry for my reply. Just as my suggestion-meanings; Will be good if there will be response from F-Secure (which you expected).

     

    Thanks.

  • F-secure13F-secure13 Posts: 6

    Thanks for your reply!

    One question more.

    I tried to check the version of the FS protector-beta on my computer.

    If I try to use the button "My FS Protection" (from "FS Protection - Instruments"), I can only see only the title "502 Bad Gateway, nginx"
    Is this a mistake?

  • UkkoUkko Posts: 2,895

    Hello,

     

    I think, yes.

     

    But just as additional meanings (for first):

     

    --> If you want to check which build installed:

    you able to use next steps: right-click for tray-picture (FS Protection) and choose 'About' (there will be something as "fs protection 17.0" and than strings like "Common Component Framework 2.90 build 182"); If you have such string - it mean that your experience about TP190 (2.90 -> TP190); if something other... so 2.87 is TP187 (as example);

    or you able to use 'About' from Main UI (where will be modules AV and Online Safety with related strings about build number, which should be for current TP-build);

     

    --> what about button 'My FS Protection' (maybe I already forget how it was with previous TPs):

    I not sure - which one button there you mean; Previously it was available from right-click tray -menu (top string) or from left-panel of Main UI  as string (after 'Tools'-tab probably and near 'Beta feedback'-string);

     

    With my experience and TP190 - 'button My FS Protection' still available from right-click tray menu; And also from Main UI as 'login'-button under next tab after "Tools" (Instruments); but not as button under Tools(instruments?)-tab;

     

    But it does not matter probably;

     

    --> Because with my experience there normally opened My FS Protection Portal.

     

    And if you get ""502 Bad Gateway, nginx"" - there is trouble/mistake or something temporarily with troublepoint. I have small experience (not often) with related mistake when trying to use My FS Protection Portal (but not so often; and usually around 'not common' steps);

     

    Most likely if you able to repeat it - good to create fsdiag (by F-Secure Support Tool) and ticket-report under beta-portal;

     

    Sorry for my reply and suggestions. Smiley Sad

     

    Thanks!

     

  • F-secure13F-secure13 Posts: 6

    * The "Allow Web Site" option exists. But this option did not work before and does not work now!


    ** Blocking of absolutely safe sites continues.
    Changing the firewall settings does not always help.


    So, still it absolutely needs to disable FS protection beta to restore communications!!

  • UkkoUkko Posts: 2,895

    @F-secure13 wrote:

    * The "Allow Web Site" option exists. But this option did not work before and does not work now!


    ** Blocking of absolutely safe sites continues.
    Changing the firewall settings does not always help.


    So, still it absolutely needs to disable FS protection beta to restore communications!!


    Hello,

     

    Sorry for my reply and my ask.

     

    Do you able to re-check some points?

     

    --> For me 'Allow Web Site' not work with current TP-builds with next situations:

    - briefly after upgrade for TP-build (before restart system);

    - after internal crash (?!) for some of FS Protection processes, which trigger 'reload' tray-picture (as visible indicator of such situation);

     

    With any of such situations - can be helpful restart system.

    Do you able to re-check with steps like: restart system -> trying to access blocked-page -> trying to allow such page;  Button should work.

    If this not work anyway - as workaround - you able to open FS Protection Main UI -> Tools -> List of allow/deny websites (allow/deny websites) -> add blocked-page-url to allow-list; Re-check if page will be allowed with next access try;

     

    --> About 'blocking safe sites' - do you able to provide this URLs (just for re-check  - if it also blocked with other systems/users and with my experience)?

     

    ===========

     

    With any meanings - most likely useful to create ticket under beta-portal with attached fsdiag.

    Also maybe your situation about something else (and was not related with 'known' troubles) - and buttons or other did not work (or wrongly work) based on another troubles.

     

    ===========

     

    Good if you will be back with feedback about my suggestions.


    Thanks.

This discussion has been closed.