Browsing Protection might be corrupted with Google Chrome 53.0.2785.89 m (64-bit)

Hello


according to Google Chrome, the extension "Browsing Protection by F-Secure v. 2.167.4181" installed by F-Secure Internet Security "might be corrupted." Unfortunately, a new installation of Chrome or browser extension on F-Secure does not work. Problem occurs for me on all PCs with the latest Chrome version 53.0.2785.89 m (64-bit)

 

Will there be an Upgrade to solve this problem?

 

Greetings

Best Answer

Comments

This discussion has been closed.