Freedome NEVER starts automatically when my Windows 7 computer comes out of sleep OR hibernation

To be clear, it's the VPN connection that NEVER starts automatically when my Windows 7 computer comes out of sleep or hibernation. The Freedome software is running after sleep and hibernation, but I ALWAYS have to manually connect to the VPN by clicking on the icon on my taskbar to open up the Freedome control screen.

 

Is that normal? I thought that the VPN should always start automatically. More than once I've started browsing websites without the VPN connected and then I have to kick myself because I realized that I forgot to start it again before opening websites.

 

The VPN connection starts automatically when the computer is completely off and then turned on, and it also starts after the computer is restarted.

 

All three of the options under Settings have a check mark, I haven't missed a step there.

 

This is happening on 3 different computers. One computer is version 1.0.2352.0, the other two might be an update or two behind but should be pretty close to the same version. All three computers are using Windows 7, fully updated.

 

 

Answers

  • LakshLaksh Posts: 4,424

    Hi NeverStarts,

     

    As mentioned in the post here, this is already reported to our RND and we are looking on resolving it as soon as possible.

  • I have reported this problem to F-Secure some weeks ago, but so far there is no solution. I find it rather disturbing that Freedome protection does not come on automatically when starting the pc from sleep mode (hibernation) and hope for a speedy remedy.

     

    I am running Windows 10, fully uptodate, and my Freedome version is 1.2729.0 (latest?).

  • BenBen Posts: 2,640

    Hi, 

     

    We have a fixed version which includes a fix for this problem. It should be available as the next release coming in a couple of weeks. 

     

  • Thank you for your response, I appreciate that you are keeping us updated.

     

    Which version has the fix?  I just updated to 1.2.2729.0 and the problem still happens - Freedome did not connect when my computer came out of Hibernation.

  • Seems that the problem with Freedome oversleeping (not waking up after sleep or hibernation) has been fixed in ver. 1.2.2729.0. My Freedome now comes on automatically, at least for the time being, every time I restart my browser (Firefox) from sleep.

  • Should have added that my pc runs on Windows 10 (latest updates) and that my comment may well not apply to Windows 7.
  • BenBen Posts: 2,640

    Hello Neverstarts,

     

    Can you confirm that Freedome is still not reconnecting after sleep even if you give it a minute or two with the latest version?

     

    If so please open a support ticket so we can investigate further.

     

     

  • Surprisingly also I found out today that Freedome did not restart automatically when waking my pc out of sleep. This may be a random occurrence, but should not happen at all for Freedome to be a reliable partner in security.

     

    Seems there is still some need for basic finetuning the Freedome software. Hope this is done fast so we can put this problem behind us.

  • Same surprise also today: Freedome did not restart automatically after wakeup from sleep. Apparently this is no random occurence but a system related issue needing correction.
  • Again the same random  problem: Freedome did not start automatically this afternoon, when waking the pc out of sleep; a manual start was necessary to initiate the program. Why is this, sometimes Freedome wakes up from sleep automatically, sometimes not?

  • BulbheadBulbhead Posts: 27

    This is just to repeat my message of Jan 25: when waking up my pc (Win 10, updated) from sleep/hibernation, Freedome sometimes comes on automatically, sometimes not. I have not been able to determine any pattern in this random behaviour. I thought that the latest update to Freedome (ver. 1.3.2906.0) might correct this, but unfortunately this is not the case.

     

    I experienced this problem again today acoompanied by this error message (in Finnish):

    "VPN alustusvirhe. Salatun VPN yhteyden luominen ei onnistu verkkoasetuksissa olevien ongelmien vuoksi (netsh.exe palautti virheen). Tarkista, että IPV6-liikenne on otettu käyttöön."

     

    I checked the network settings and IPv6 was marked with x (on); so that could not be the reason for this error. There surely was something amiss, since Freedome could not be turned on from the program itself. However, a restart of the pc did the trick: Freedome came on by itself after the restart without further ado.

     

    This problem is annoying and something should be done to remedy it preferably sonner than later.

     

    A restart of the pc was enough to

  • Looks like it's been fixed!

     

    I recently upgraded to 1.3.2906.0.  Since then Freedome has always started after my computer comes out of both Sleep and Hibernation.  I've tested them both a dozen times over several days and everything looks good.

     

    Please send my warm thanks to the devs for fixing this problem!  Not auto-starting after Sleep and Hibernation was the only reason that kept me from installing Freedome on my family members' computers.  Now that it's fixed, I feel comfortable setting it up for them.

     

    Thank you!!!!!

     

     

    Problem came back  - see below

     

  • BulbheadBulbhead Posts: 27

    Sorry to say, theoriginal  problem persists, and from time to time (like today, once) Freedome does not come on automatically though it most of the time does. The error message refers to IPv6-problem (on checking the network connections I found that FreedomeVPNConnection was marked with red cross meaning it was off); this happened during a period of sleep/hibernation lasting about one hour. Seems there is still some checking to be done by the Freedome team at F-Secure!

     

    Win 10, latest updates, Freedome 1.3.2906.0.

  • BenBen Posts: 2,640

    Hi bulbhead, 

     

    If the issue persists with the latest version, could you open a support ticket so we can look better into it?

  • BulbheadBulbhead Posts: 27
    Done.
  • Looks like I spoke too soon, the same problem happened again a little while ago - my Windows computer came out of Hibernation and Freedome didn't auto start.  That's too bad, it had been working flawlessly since the update.

     

    I can open a ticket but I'm not comfortable sending the entire FSDIAG.ZIP - it contains too much identifying information about my computer.  Are there specific files I can send instead of sending the entire ZIP package?

  • Update - since my last post, the problem has not happened again.  It could be that the one time Freedome didn't start was because I didn't have it connected when I shut the computer down.

     

    I'll keep a close on it and post again if I experience any more problems.

  • tvihtvih Posts: 1

    For me, on my laptop Freedome usually reconnects VPN after sleep mode. On my desktop computer, it never does. Version is currently 1.3.2906.0, but have had the problem for several months, ever since I started using Freedome. Because I generally forget to turn it on manually, I'm "unprotected" most of the time...

    Windows 10 on both machines, by the way. On my secondary HTPC desktop computer with Win7 64-bit the **bleep** thing won't even work at all because some driver wasn't signed and wouldn't install.

This discussion has been closed.