SAFE license renewal process did not activate SAFE

Hi

 

Safe have been noticing me arond month that my subscription is ending and do I want to renew it. I answer yes. Yesterday was last day for previus subscription and I paid renewal for next year.

 

Now in SAFE portal I see that my subscription is valid until 23.1.2017 and 364 days left and 0 license left (all 5 liceses are in use). But below that all listed computer are in orange color and if I clic any of them open it says that computer is unprotected and my subscription is ended.. Same goes to actuan SAFA applicagtions in computers.

 

I cannot release licensed or do anything from portal. I even uninstalled SAFE from one computer but it did not release license eather.

 

Over all I have paid licenses and all my computers are unprotected.

 

Please, check fast what is wrong with my accout!

 

Rgds

Henry

flodeJVREmiliaAriadnesassa

Comments

  • flodeflode Posts: 2

    I have the exact same issue here.

    My machines are orange. I cant add new machines and my computers tell me my licence is not valid.

    In my safe account it says over 1000 days left.

     

    Please get your stuff fixed! My machines are unprotected!

     

    fsec_bug.PNG

    JVRAriadnesassa
  • Hello,

     

    I have the exact same problem as above except I paid for two extra licences to have extras for future purchases of surfpads/phones and now all my devices are in orange and unprotected. My SAFE account confirms I have a valid subscription period. I am not able to release any devices - the option to do so is simply not there (I am allowed to change the name for each device only). Please fix immediately!

     

    Thank you.

  • Exactly same for me. I had three licenses. Then I added two more. Now all units says that licence has expired but on My f-secure it says valid until 2017!!??

     

    //pekka

  • Same Problem here! Had 5 SAFE Licenses with ~ 20 days to go. The I used two Codes (10 licenses,1 Year each) to extend the licenses. That worked well an the correct dates were shown. But now all of my installations say that the subscription has ended. Manual update does not fix the problem. However, my account shows the correct number of licenses and expiry date (Feb 2018). Please help!
  • pivi75pivi75 Posts: 1

    Same problem here. I have 3 licences for 2 years left and the devices show subscription has ended but when logging to my f-secure it shows not installed. 

  • Same story here,

     

    I bought 2 additional licenses 2 days ago, F-Secure Safe tells me since then that my devices are unprotected. All of them now 2 days and no fix yet.

  • jpartmjpartm Posts: 1

    Same here. Renewed yesterday and still notices me that my devices are unprotected. I have tried reinstallation and check updates manually but nothing....

  • EpixiEpixi Posts: 1

    I'm on same boat, renewed license 24th and today license is already expired... Oh well time to wait CS from F-secure and Cleverbridge to reply back to see whats the issue

  • VetraciVetraci Posts: 156

    I would recommend to get in contact with F-Secure customer support:

     

    Chat with an F-Secure expert: Global (English)

     

    Chatten mit einem F-Secure Experten: Deutschland (Deutsch)

     

    Call F-Secure customer support: Check phone numbers and service hours

  • sassasassa Posts: 1

    I'm having the same problem as people above and tried the chat but was disconnected / kicked from there after waiting in the queue for 5-10 minutes.

  • I try also connect to technician 3-4 times, every attempt was timed off and disconnect even i try use support in Finnish or English.

  • I got in touch with the support.

    They told me that this is a known problem. Thay have to synchronize my account (whatever this means).

    I've been told that I will get updated this afternoon.

     

    I also told them that there are more people on the foums having the same problem. So there is a chance that this will be solved. However, if you didn't do it yet, write them a ticket.

  • JouniJouni Posts: 135 F-Secure Product Expert

    Hi all,

     

    We are aware of this issue, and we are currently working on it to get it solved as soon as possible.

     

    We will let you know once this has been fixed. We are very sorry about the trouble.

  • Hi

     

    Thank you Jouni replying.

     

    I was on phone with F-Secure support earlier today and he said that SAFE on workstation works only partly because of this and recommened to be careful opening email attachements and going to suspicious or unknown (to you) sites.

     

    So in other words, use your common sence. :)

     

    Rgds

    Henkka

     

  • JouniJouni Posts: 135 F-Secure Product Expert

    Hi all,

     

    Now the problem is fully fixed and your SAFE subscriptions should be properly updated.

     

    We are very sorry for all the trouble you have faced because of this issue.

  • My licenses are working again. Thanks!


  • @Jouni wrote:

    Hi all,

     

    Now the problem is fully fixed and your SAFE subscriptions should be properly updated.

     

    We are very sorry for all the trouble you have faced because of this issue.


    Still same issue. Smiley Sad

     

    Second month wasting money and being unsecured. And no reply from support either.

  • JouniJouni Posts: 135 F-Secure Product Expert

    Hello Faijoni,

     

    Apparently the problem in your case is bit different. Could you please send me a private message with the support request number, so that I can find the case and have a look.

  • Hi

    Now Safes are working but they needed uninstall and releasesing of license and reinstall Safe from beginning.

    Rgds
    Henkka
  • PP3PP3 Posts: 1

    I have just , renewed safe , the problem exist still .I dont get my licences .

     

    rgds PP

This discussion has been closed.