Licence renewed but message saying my licence has expired and my devices aren't protected.

I renewed my licence a couple of weeks ago as a V M customer. I log in and I can see my account has updated this to show I have renewed until July 2016, but my devices are saying that my licence has expired and my devices are no longer valid? Anyone know why this is and how to ensure they are protected?

Best Answer

  • TrickTrick Posts: 5
    Accepted Answer
    Sorry, it won't let me send this screenshot. I keep a message that an invalid HTML has been removed and I should recheck the message and resend, but keep getting the same message!!! I could PM you if I knew your email address?

Answers

  • JouniJouni Posts: 135

    Hello Trick,

     

    In this case I would suggest the instructions found from following article:

    http://community.f-secure.com/t5/Security-for-PC/I-have-renewed-my-F-Secure-SAFE/ta-p/63457

     

    If that didn't help, please open a support request at:

    https://www.f-secure.com/en_GB/web/home_gb/support/support-request

  • TrickTrick Posts: 5
    Thanks Jouni. These instructions worked for my Android phone, buy not my Mac. It's still showing This Licence is inactive. This computer is not protected. So I have opened a support request as you advised. Strange though that when I click Check for Updates it then goes on to say that my protection is up to date! On my ipad it says my licence is valid and has 361 days to run, but below still says this device is not protected and I should renew my licence....
    Best regards,
    Trick
  • TrickTrick Posts: 5
    Jouni, I have heard from your technicians and they have told me to uninstall SAFE from my Mac and reinstall it. I have uninstalled it, but there is nowhere on the portal now that is offering a Download and Install option. Under my devices, it just has an exclamation mark on my Mac and Phone with the words, License not in use....but with nowhere to click download, though it's still telling me that my licence is valid for another 360 days. How do I get it back on?
  • JouniJouni Posts: 135

    Hello Trick,

     

    There should be "Remove" and "Reinstall" links inside the same box where it states "License not in use". In this case you can click the "Reinstall" and proceed with the download from there.

  • TrickTrick Posts: 5
    Unfortunately, no, there isn't. And if I click on Mac a bubble comes up that says install client application on Mac....but no link to do it. I'm getting really fed up with this now Jouni as I've spent hours logging in and researching help topics etc...
  • JouniJouni Posts: 135

    Hello Trick,

     

    Correct me if I am wrong, but was it so that the "Remove" and "Reinstall" links are both missing?

     

    As this sounds quite odd, could you please provide a screenshot of that view?

This discussion has been closed.