F-Secure 2012 Deepguard blocking MS programs

As of this morning, I was unable to load any Microsoft products, including all elements of Office 2010, Windows Live Mail and Windows Live Messenger. The message received was simply 'x has stopped working'.

After much experimenting and some help from a technical specialist, I discovered that disabling Deepguard APM allows me to access the programs again.

I'm now concerned that I don't have the APM protection - is there a way of enabling APM to allow the MS applications that it was previously fine with?

AF

Best Answer

  • SiltanenSiltanen Posts: 108
    Accepted Answer

    Hello All,

     

    We've released an automatic update labeled "F-Secure DeepGuard Update 2012-03-15_01" to all Internet Security 2012 users.

     

    There's no need to use the beta fsdbupdate9.exe I posted earlier to this thread.

     

    We're are confident the update will solve the issue and are looking forward to your feedback.

     

    Thanks,

    Siltanen

Answers

  • nayan007nayan007 Posts: 48

    Allow programs that DeepGuard has blocked

    To allow a program that DeepGuard has blocked:
    1. On the main page, click Tasks.
    2. Click Allow an application to start.
    The Monitored applications list is shown.
    3. Click the Permission column to sort the list into groups of allowed and denied programs.
    4. Select the program, which you want to allow, and click Details.
    5. Under Permission , select Allow.
    6. Click OK.
    7. Click Close.
    The program you selected is now allowed to run and make system changes.

  • What operating system is installed (e.g. Win7 64-Bit)?

     

    EDIT: Have you installed today any Microsoft (system or office products) updates?

    Baybe they are the reason for this problem.


  • ftmkftmk Posts: 4

    nayan

     

    Thanks for this, but the MS applications are not listed in the Monitored Applications panel - and there is no option to add new applications, just to remove or see details of ones already in the list.

  • ftmkftmk Posts: 4

    motec-data

     

    It's win7 32-bit. Nope didn't change a thing between last night and this morning, no new programs added. Just powered up this morning and thhey weren't working!

  • AFAF Posts: 1

    I am using Win 7 - 64 bits and it is the same thing. Outlook 2010 and Streets & Trips 2010 & 2011 will not work. Disable Deepguard and Presto! they work again.

     

    Please get this fixed, I really don't want to go along withot Deepguard for too long.

     

    Thanks!

  • JaysonJayson Posts: 595

    Hi,

    I apologize for the inconvenience caused. We do aware of this issue, we are currently working on to fix it. Please disable the APM for the meanwhile as a workaround.

    @ftmk and @AF,

    Much appreciate if you could send an e-mail to our support: [email protected] with FSDIAG attached. This would be a great help to us in resolving the issue.

     

    [Moderator edit, this email address is no longer in use, please refer to the web form:

    http://www.f-secure.com/en/web/home_global/support/contact/request]

    Once done this, kindly PM me the SR ID number received.

    Thanks.


    Best Regards,
    Jayson

  • Bumped upon the same problem. The problem seems to not be the whole Deepguard, but rather the Advanced Process Monitoring since disabling the option "Use advanced process monitoring" makes things work again properly. Might be the programs are trying to make some sort of a check which the advanced proecess monitoring does not like. Weird thing about this is that my other computer is fine, my other isn't. They're both having automatic updates on, so might be one of them haven't updated and the other has. Both are laptops, the one not working has Vista 32-bit, the other has Windows 7.

     

    Hopefully you (Or Microsoft) come up with a fix eventually.

  • ftmkftmk Posts: 4

    Jayson

     

    As requested I have sent a fsdiag file to support. Hope you can get us a fix soon!

  • mVnmVn Posts: 2

    Exactly the same problem here.

    All office products show on startup an license error.
    But there is no license error.
    Windows Live Messenger crashs on startup by a app-crash.

     

    Please fix it...

  • StephanStephan Posts: 351

    Hello,

     

    We are currently working with high priority on the issue.

     

    Until it is resolved, please disable DeepGuards advanced process monitoring.

    Your MS Office applications will start again.

     

    Sorry for the inconvenience.


    Best regards,

    Stephan

     

  • will this problem be fixed automaticly (by updating fsecure after ure fix is done) or do we have to do something manully?

     

    thx

  • StephanStephan Posts: 351

    Hi oversiZZed,

     

    We are aiming towards a fix that requires no user action.

    However it is a bit too early to tell for sure.

     

    I'll post here once I have more information.

     

    Best regards,

    Stephan

  • rodamonrodamon Posts: 1

    24h looking for the problem... until I found it was from Deepguard, not Office... Unistalling Office, restoring system... Smiley Frustrated

     

    Please, when you find some trouble like this send quick a post to all the users!!!

     

    Thanks.

  • chesschess Posts: 46

    me too.

    at first I was reading in the office support. then I reconized, my laptop do not have installed the last microsoft-updates.

    after this, I know, whos fault.

    disabling the advance monitoring setting from deepguard... and it works.

     

    regards

     

  • nayan007nayan007 Posts: 48

     Hi chess,

    It is nice to know that you have found solution of your problem by ownself

  • chesschess Posts: 46

    interesting:

    Q U O T E : 

    Most of our customers are unaffected, for those unfortunate few that are experiencing related problems a quick and simple workaround is to disable “Advanced Process Monitoring” from the products user interface.

    U N Q U O T E :

     

    we are all affected! most of our pc using win 7 64 bit. in my opinion, there is no reason to sent a fdiag, because there is no different using it with a or b. i even do not see relationships between the windows/office updates....

    crazy.

     

    but no security software should do like this...

    sorry my opinion.

     

  • chesschess Posts: 46

    i have to really figuer out very high, what is the problem.

    please tell me, what is M$S doing...

  • VäsyVäsy Posts: 1

    Hi!

     

    My customer had (and to some extent still has) the same problem. Had to find a quick workaround for the customer, who was getting jumpy. Checked the path info of the icon of each Office 2010 program and noticed that the user profile name of each path had been changed to "Public". Created new icons for every Office program and when starting each program I went in the opening window to "Compatibility check". That gave just one alternative: Windows XP 32-bit. That option was chosen  and the program opening command opened on the screen a window asking whether the user wants to continue. Answering YES opens the program and it works normally. All this without touching Deep Guard settings. OS is W7 64-bit.

    Have to admit that we are desperately waiting for a fix from F-Secure! 

  • SiltanenSiltanen Posts: 108

    Hello All,

     

    We've released a potential fix for this issue to our beta deployment channel. Could you give it a try?

    Just download and execute the following package on the problematic machine: http://download.f-secure.com/latest/beta/fsdbupdate9.exe

     

    Regards,

    Siltanen

  • chesschess Posts: 46

    strange... but office works

  • chesschess Posts: 46

    I only apply this on one machine, every other has to be fixed by you!

     

  • nayan007nayan007 Posts: 48

    I too have the similar kind of problem,after applying the fix it resolved my problem

  • Windows 7 64 / Tried with Deep guard turned off.

    Affected software: Ocenaudio

     

    It will upload small sound files but will stall with 1MB files. It works fine on the other PC with no F-Secure installed. Please help me out. Thank you for your time.

  • SimonSimon Posts: 2,574

    Hi,

     

    If you've tried with DeepGuard turned off, then that suggests another cause of the problem.  However, I think your best bet might be to raise a support ticket with F-Secure, includiung an FSDIAG, so that they can investigate the issue more fully.

This discussion has been closed.