Internet connection not working

So, after installing F-Secure my computer has been unable to find an internet connection.  First I figured the problem was in the firewall settings, but there was no connection even after I switched off the firewall. My bag of tricks is empty and I'm getting really frustrated. What to do? 

Best Answer

  • viktikviktik Posts: 62
    Accepted Answer

    uninstall both driver fron device manager.

    then click action-> scan for hardware changes from device manager.

     

     

    If this does not work then probably you need to download new drivers.

    It can be done by windows automantic update or you need to dwonload the driver manually.

Comments

  • viktikviktik Posts: 62

    How do you connect to internet. Dialup, LAN, USB modem ?

    Whats the operating system?

     

    Go to Control panel-> Windows firewall. then try to restore default. See if this works.

     

    try to ping www.google.com in CMD. See if that happens or not.

     

    Scan whole C: drive with f-secure.

     

     

     

     

  • SampzzaSampzza Posts: 3

    LAN, Win8

     

    So I tried all of those, still nothing.  Now I've also noticed that after installation the Windows troubleshooting has found a problem with the following drivers: Qualcomm Atheros AR9485WB-EG wireless network adapter and Qualcomm Atheros AR8161 PCI-E Gigabit Ethernet. The troubleshooting wasn't able to fix it.

     

    I also tried deleting F-Secure, but the laptop still refused to connect to the internet.  I got it to work by system restore.

    Now I've installed F-Secure again, but the same problem still exists. 

     

  • SampzzaSampzza Posts: 3

    Wow, that actually worked. Thanks for your assistance!

This discussion has been closed.