Freedome doesn't work after rebooting computer

I can't connect to the Internet when I have Freedome turned ON.

If I reinstall the program, it works only until I reboot the computer. Then I have to reinstall it again.

I saw an old thread with a user who seems to have had the same issue:

https://community.f-secure.com/en/discussion/104316/freedome-only-works-spuatically-after-rebooting-pc-it-doesnt-work-or-show-up-in-task-bar

Any fix for this?


Gustav

PeteS1

Answers

  • JaimsJaims Posts: 416 Moderator

    Hi @ynkryggen_robert

    Was there any recent Windows Update done on your PC?

    To try to fix the issue by resetting the DNS cache on your computer.

    Open the command prompt as an administrator. Click the Windows start button > Type "cmd" > Right-click Command Prompt > Click Run as Administrator.

    In the Command prompt, type the command below. After each command, press Enter to execute.

    • ipconfig /flushdns
    • netsh winsock reset
    • netsh int ipv6 reset

    You can restart your machine and check again.

    If the above steps do not help, the issue might be that your firewall is blocking the connection. If that is the case, you need to change your firewall settings to allow the connection.

    Our Android, Windows and macOS products use the OpenVPN protocol. The ports for Android, Mac, and Windows are:

    • TCP/UDP ports in the range 2700 - 2800
    • TCP port 443

    Allow traffic on these ports in your firewall and try to connect Freedome again. Refer to this video on how to open the Windows Firewall and configure the ports: 

    Check if automatic killswitch is enabled. Here's how to check.

    1. Open F-Secure FREEDOME VPN
    2. Click Settings

    The automatic killswitch is the 4th button under Connection & Status. If it is turned on,

    1. Click Allow connections to other devices in trusted networks
    2. Check the network you're currently connected to
    3. Click Save

    Let's know if this works.

    Lucaseuropa
  • ynkryggen_robertynkryggen_robert Posts: 2 New Member

    Hi,

    I've now tried each of these methods. Forwarding ports in the Windows Firewall seemed to provide a temporary fix. But after restarting my laptop, I'm back on square one. Still no Internet Connection with Freedome turned on.

  • JaimsJaims Posts: 416 Moderator

    Hi @ynkryggen_robert

    You can also try reinstalling the F-Secure FREEDOME TAP driver. To uninstall the F-Secure FREEDOME TAP driver using pnputil tool:

    1. Uninstall F-Secure FREEDOME using the Windows Control Panel 
    2. Restart the computer
    3. Open a Command Prompt (Run as administrator) window
    4. Type in command: pnputil -e >list.txt and press enter. This creates a list.txt to the folder where you ran the command. 
    5. Figure out which *.inf file is associated with the F-Secure Freedome TAP driver by searching the word "F-Secure" from list.txt
    6. Run the command: pnputil.exe -d oem<NUMBER>.inf (this will remove the driver)
    7. Restart the computer
    8. Reinstall F-Secure FREEDOME VPN

    Specific programs made to optimize network performance for example switching between different network connections or deciding how different software is allowed to use the network might also cause issues with Freedome. If you are aware of such software installed on your computer, try turning it off to see if it has an effect.

    Lucaseuropa
  • DroobDroob Posts: 2 New Member

    I have this same problem on mac since the last update. When i restart my connection is blocked.

    The hack fix is to turn freedome off and then back on, but this is not good.

  • JaimsJaims Posts: 416 Moderator
    edited October 28

    Hi @Droob

    An investigation is ongoing and will update you once there is an update.

    Workaround for now is to disable/enable Freedome network interface once after every reboot by running following commands in admin command prompt:

    netsh interface set interface FreedomeVPNConnection disable

    netsh interface set interface FreedomeVPNConnection enable

    In the meantime, please ensure you have Freedome VPN updated to the latest version.

    Lucaseuropa
Sign In or Register to comment.