Browser extension missing again in Safari

This problem seems to have resurfaced with the 17.7 update. Need to untick-tick every time again.

Accepted Answer


  • UkkoUkko Posts: 3,208 Superuser



    There is a fresh Knowledgbase article:

     Could you try to chek it?

  • "To uninstall “Browsing protection”, you must remove the “F-Secure SAFE” application".


    Did that already.

  • UkkoUkko Posts: 3,208 Superuser



    Sorry for my reply. Just as a clarification - I am also only an F-Secure user (their home solutions and mostly Windows platform).


    "To uninstall “Browsing protection”, you must remove the “F-Secure SAFE” application".
    Did that already.

    If it was a real quote - then I did not find these words under provided Knowledgebase article.

    If article was not useful and helpful, then you could try to contact their (F-Secure) official Support channels. For example, web-chat:

    Sorry if I wrongly read your sentence. Good if you can to clarify about exact trouble point. Or whether it just with meanings that your do not want to deal with it anymore.



  • Thanks for pointing to the article. I did go through the three scenarios in the article. They advice to reinstall the protection extension. However, that requires a full reinstallation of the SAFE. I did that, and it did not change anything.

    The problem might lie with my still using macOs 10.14.6, not the latest one. In that respect I'm stuck because I cannot upgrade due to lack of some critical drivers.

    I'll leave this for now.

  • I run the latest version of macOS Catalina (10.15.3, build 19D76) with the latest version of Safari (13.0.5, build 15608.5.11) and the latest version of F-Secure SAFE (17.7, build 31227) and can confirm that this problem does indeed replicate when using the latest versions. The problem only occurs when starting Safari, not when running the latest non-beta versions of Mozilla Firefox (73.0.1, version ID 20200217142647) or Google Chrome (80.0.3987.116) under the same operating system.

  • CaleCale Posts: 122 F-Secure Product Manager


    We have found an issue in the product where it falsely notifies about missing Safari extension in certain scenario.

    We are releasing an update in a week or so that should fix this issue. We apologize for the inconvenience.


  • LesBLesB Posts: 5 New Member

    Any progress on this please?

  • CaleCale Posts: 122 F-Secure Product Manager


    Maintenance release for released in mid March. You can see the latest version number in the About. You should be running 17.7, build 31693.


  • IBozz1861IBozz1861 Posts: 3 New Member

    I'm using v17.7, build 31693 running with Safari v13.1 (15609. under macOS v10.15.4 (19E287) Catalina and i still get he warning.

    It appears to be at random - if there is a pattern (I'm sure there is somewhere) then I've failed to notice it yet.

    Has the bug been fixed? If not when do we hope to have a fix and, if it has, then why might I still be getting it?

    Any advice, please?

  • LesBLesB Posts: 5 New Member

    And I'm using v17.7 build 31693 with Safari 13.1 (build 13609. with macOS 10.13.6 High Sierra and am still getting the problem.

    It must be 3 or 4 months now since I had a long session with a tech support person who took over my m/c, uninstalled and re-installed several times and eventually said the next release would fix this.

    When I look in Safari, it says the FSecure browser extension is active, yet FSecure keeps telling me it's not. This is not just frustrating, but makes me unsure whether my machine really is protected.

    Can someone in FSecure with the appropriate knowledge please give a 100% guarantee that this warning is a spurious error and the browser extension is both loaded and working correctly?

    If not, can someone suggest a better piece of software??

  • ArthurValArthurVal Posts: 108 F-Secure Employee


    Sorry to hear that you are facing an issue with browsing protection feature provided by SAFE.

    I understand that the message that you are referring to may bring confusion on whether the browsing protection feature is working properly. You can always verify that browsing protection is working properly by visiting any of the supported search engines (Google, etc.). If you see the rating icons injected by the browser extension, then there is no critical issue with the extension itself.

    Please be advised that we have made further adjustments to SAFE acknowledgement of the browser extension state for an upcoming release. We are currently testing the implemented solution to verify that the issue is resolved. Please stay tuned for updates.

    In the meanwhile, if you do not mind assisting us in verifying that the upcoming changes are targeting the same issue that you are experiencing, could you please submit SAFE diagnostics to F-Secure Support?

    Please launch the "Support Tool" app which is shipped with SAFE (the default location is /Applications/F-Secure/Support After you press "Run Diagnostics", it will start generating an archive with diagnostic information about SAFE which could be useful for us to isolate the issue.

    Please attach the file that Support Tool created to your support request. Thanks in advance!

    Best regards, Arthur

    SAFE Mac R&D Team

This discussion has been closed.