Mac OS Catalina Dock Problems Resolved with F-Secure Safe Uninstall

I have been having horrible problems with the dock on my MacBook since the install of MacOS Catalina.  I have been on the phone with Apple Support multiple times with no resolution.  We've tried everything including reinstalling the OS with no fix.  I finally noticed that when starting up my MacBook, that whenever the desktop appeared and the status bar icon showed F-Secure Safe was updating - I always had dock problems.  When Safe was not updating during the startup process, no problems.  I have now completely uninstalled F-Secure Safe and all of my dock problems are magically gone.


These dock problems are very widespread, and I doubt everyone affected is using F-Secure Safe, but it seems that Catalina and F-Secure Safe (and possibly other AV) are not playing well together.  I hate to leave my machine unprotected, but it's unusable with F-Secure Safe installed on Catalina.  What's the fix for this?


Accepted Answer


  • I tried reinstalling with a freshly downloaded F-Secure Safe installer and boom, all the problems came right back.  The issue is definitely something between Catalina and Safe.

  • pajppajp Posts: 84 F-Secure Employee



    can you be more specific about the issues you're having so that we can investigate further? Detailed symptom descriptions would be very helpful for us to be able to reproduce this issue in-house.


    I would also recommend opening a case with our support so that we can track this issue properly:

  • Is there a way to open a ticket without getting tied up on the phone with someone?  I don't have time during business hours to be on a phone call troubleshooting my personal MacBook.  The specifics are that the dock would not appear on boot/reboot, when the dock would occasionally be visible the dot indicators under icons to indicate open applications would not appear, then when certain applications would launch like Safari, the dock would disappear and would not be accessible.  Running "killall Dock" at the terminal would temporarily bring the dock back up and get it working for a time.  I noticed that the dock did not show up at all on boot if the F-Secure Safe icon in the menu bar indicated that it was updating as the computer was booting.  This was what led me to uninstall Safe and resolve the issue.  There was also a stuck, unresponsive process located at /System/Library/CoreServices/Installer Progress every time I had dock problems.


    Apple has noted from my case that your software (and a few other AVs) are causing this problem and they will be advising anyone who has F-Secure Safe to remove it as a fix going forward based on my case.  You all probably need to get on a fix, because I am not the only one with this issue.  I have had to switch over to Malware Bytes temporarily for malware protection until you get this resolved.

  • SethuSethu Posts: 720 F-Secure Employee

    Hello @RandomGirl 


    I have now escalated this post to our F-Secure support team. You will get a response from them soon.

  • The same with me. After many times clean installations of Catalina, Fsecure was again THE problem!

  • It's really annoying.  I've got a 2 week trial of MalwareBytes installed for now.  The support team keeps wanting me to reinstall it so I can send logs, but I don't have time to trash my computer again right now.  They are acting like I am the only person having this problem.  I think I may just buy MalwareBytes, because I don't have time to do their job for them.  Apple already has it in their database for their support people to have customers with this problem remove F-Secure, so I guarantee it's affecting way more than just me.

  • s7cribs7crib Posts: 1

    I have the same problem, unfortunately I had to uninstall F-Secure Safe from my mac.

  • pajppajp Posts: 84 F-Secure Employee



    for what it's worth, we're working on this inside R&D as well. We have reproduced it on some computers but not others and have not yet identified what the circumstances are that causes this to happen. We in R&D therefore asked the support team for more system logs because it can help us narrow down the exact configuration causing this to happen. Rest assured that we're trying to find a solution.


    - Rasmus, F-Secure SAFE for Desktops R&D

This discussion has been closed.