F-secure BETA website cannot be access

Hi All,

 

I can't seems to access to Beta F-secure website. It gives a DNS Error.

I did not have a clue as to what had happen to the site. 

 

 

Ukko

Comments

  • UkkoUkko Posts: 2,964

    Hello,

     

    Maybe, it is only temporary misconfiguration (or kind of it) for certain instance. But, I do able to recommend "do not visit the beta portal" on current time. Just for sure.

    At least, situation sounds strange. There is a redirect(?!) with some forms (certain circumstance).

    // edited later: some claims are removed. since unsupported by anything.

     

    Good to receive an official attention from F-Secure. Or an explanation about.

    Although, inability to use website under HTTPS is pretty and good mitigation (probably).

    Jaims
  • RusliRusli Posts: 991

    Hi

     

    Today Beta F-Secure site is totally down again. 

    Ukko
  • UkkoUkko Posts: 2,964

    @Rusli wrote:

    Hi

    Today Beta F-Secure site is totally down again


    // remark: I am only an F-Secure user (their home solutions).

     

    I think this is during all week (occasionally). I am not sure about any proper "descriptions", but my own unofficial feelings are:

    - beta portal (domain) with two instances ('provided' by third party service).

    - one instance with discussed trouble; another one is safe.

    - if you hit "wrong" instance, then portal is inaccessible due troubles with certificate (mismatch OR invalid cert /later/).

    Perhaps, server is configured to return "certain" instance for certain location or user (based on something). Something as balancing.

    Or instances are switching between each other time to time. As a result, based on who is primary - website is accessible or not.

     

    I tried to contact Support (one week before), but discussion got stuck then during letter discussion (probably, based on my worst explanations and wordings). And then "silence" for some days (after I tried to provide a bit more clear sentences and suggestions about reasons / situations).

     

    Thanks!

  • UkkoUkko Posts: 2,964

    Sorry for the feedback and over-the-reply.

    Sounds that today situation is fixed. Beta portal should be accessible and "safe". Although I did not receive any confirmations of it; only my own feelings.

  • RusliRusli Posts: 991

    Hi

     

    I cannot access to the F-Secure BETA site to due this error .... 

    This site can’t be reached

    beta.f-secure.com took too long to respond.

    Try:
    ERR_CONNECTION_TIMED_OUT
    Check your internet connection.

    Check any cables and reboot any routers, modems, or other network devices you may be using.

    Allow Opera to access the network in your firewall or antivirus settings.

     

    Ukko
  • UkkoUkko Posts: 2,964

    @Rusli wrote:

     

    I cannot access to the F-Secure BETA site to due this error .... 

    This site can’t be reached


    Hello,

     

    It is my experience too. Website is not accessible. Sounds that it is a general trouble (not pinned to something on user's side) with server. Maybe something with configuration. Smiley Sad

    But, apparently, it is another situation compared to original topic concern.

     

    Thanks!

  • SimonSimon Posts: 2,585

    This is a real pain!  I uninstalled FS to test a couple of other AV products (needless to say, which didn't come up to scratch), but now I can't access the beta portal to reinstall FS, so I've no security!

  • SimonSimon Posts: 2,585

    Well, I managed to find the installation file for when I installed FS on my laptop a few months ago, so I used that on my PC and am now protected again.

     

    Out of curiosity, I tried BitDefender and Kaspersky, and both fell short.  Bitdefender's banking protection doesn't work with my browser, and KIS produced a prompt for every website I wanted to visit, which I had to click to add as an exception.  Couldn't have any of that!

    Ukko
  • LateLate Posts: 4

    Are you getting "403 Forbidden"? If so, clearing the browser cache helps.

  • UkkoUkko Posts: 2,964

    @Late wrote:

    Are you getting "403 Forbidden"? If so, clearing the browser cache helps.


    Hello,

     

    My experience is not about such a state.

    My experience is about state when page is not loaded at all (just if such a domain / URL is not exist).

    In addition, it is not possible to ping domain (IP). Packets are dropped. Based on my try to check more - it is not pinned to certain location (but, maybe, works for some) and pinging is not completed. Trace route with some hops before certain stage.

  • SimonSimon Posts: 2,585

    @Late wrote:

    Are you getting "403 Forbidden"? If so, clearing the browser cache helps.


    No, I'm just getting a network time-out.

  • Lord_AmiLord_Ami Posts: 68

    Same here. I think it already started on Friday.

     

    ERR_CONNECTION_TIMED_OUT

     

    I've tried in different machines and even on my phone - the result is the same.

  • UkkoUkko Posts: 2,964

    On current minute - my experience is about:

    DLG_FLAGS_SEC_CERT_CN_INVALID

    and equivalent wording.

    Although, pinging domain is still trouble; but direct try to open beta portal with notification from browser about "certificate name mismatch" under HTTPS (and certificate indeed is about another domain / company); And "nothing" under HTTP;


    Added 31.07.2019:

    All is OK for today.

  • RusliRusli Posts: 991

    Hi

     

    I checked again. 

     

    F-Secure Beta web site is still down. 

     

    Can you please check. 

     

    I getting 404 now. 

    Ukko
  • UkkoUkko Posts: 2,964

    Hello,

     

    On current minute - my experience is also about such a state.

    F-Secure Beta web site is still down. 

    but, actually, not "still"; just "else one time". At least, beta portal was available some days before.

     

    this time - also certificate mismatch warning (or "page is not found" for http / allowed connection).

    and since it is only one instance - it should be always.

    Good if F-Secure beta team will check it more closely (trouble is too repeatable).

     

    Thanks!

  • I was having the same 404 issues for the past few days, and even checking various "is it down for everyone?" websites, it was reported as down.  I recently changed my DNS from my Pi-Hole to cloudflare, and it let me connect again.  Very strange, and I', stumped as to what was happening.

  • There has been network issues which should have been fixed already. Sorry about the inconvinience! please do not hesitate to contact in case of issue still exists.

    UkkoLaksh
  • Hi, I'm getting 404 now. 

    Can you help me? Thanks.

This discussion has been closed.