F-Secure seems to be blocking a game



Hoping someone can help me out, I Got Battlestar Galactica deadlock from steam ages back, has some good fun there.

I changed to F-Secure security as a deal with my ISP and recently decided to play Deadlock only it wont run.

I have discovered that if I disable F-Secure I can laod the game to the main menu but after turning F-Secure back on the game doesnt run and Steam gives me error code 51 which is an access Violation error.


Anyone have a solution to this?


  • UkkoUkko Posts: 2,943



    I am only an F-Secure user. Sorry for my English and reply!


    There was a discussion about some troubles with games (via Steam or Microsoft Store).

    One workaround is to use "exclusion list" for Manual Scanning. For example, to exclude certain executable or game directory. Need to do it carefully (and, in general, it is only temporary workaround).


    Solution is to contact F-Secure Labs and, for example, to transfer executable (game.exe) via F-Secure SAS:

    Another solution is to contact game developers or Steam. Just because "code 51" maybe is about internal game's protection functionality. As a result, analysis or hooks by F-Secure solution (DeepGuard module as a example) is "detected" as cheating with executable (game).


    Since your topic is located under "Home Security Beta Board" - then, maybe, good to create report / ticket via beta-portal. At least, such a thing is recommended, perhaps (and kind of replacement for F-Secure SAS / F-Secure Labs contacting).



  • FrayaFraya Posts: 7



    Thanks for the reply,

    I didnt realise where this post was, i was reading one that was closed and and clicked the new thread button.


    But yeah I'm not sure what is going on but I have the game and steam added to exceptions list but I still get this error 51 when clicking play game. I think I said that is an access violation error, I'll have to try a ticket or something as you suggested. But atleast I know that i can click the disable button in F-secure then run the game normally and I never play it online, multiplayer isnt that great to be honest.


    Its just frustrating that I can see no reason given all the exceptions are set and yet the problem is persisting.


  • yeoldfartyeoldfart Posts: 506
    did you get an answer from the beta feedback guys ?
  • FrayaFraya Posts: 7

    No not yet yeoldfart. But i dont know what their response time is so I'll assume it comes later today

  • UkkoUkko Posts: 2,943



    So, if your exclusion list is already with "excluded" game folder AND if you want to try own troubleshoot steps - then, maybe, it is possible to check:

    -- for sure: doublecheck that executable (game) is excluded (or maybe entire folder with this executable).

    -- when F-Secure is disabled and game is launched - check where is launched game (process) located.

    If need to advice about "how to do so" - just reask and I (or anyone else) will try to explain / think about!

    Maybe blocked process is located under another folder that is not excluded (for example, if game is launched from another folder even by running executable on its game folder).

    -- to check more about abilities to launch game with partly disabled F-Secure. Sounds that your current  workaround is to use "disable all security features".


    For example, could you try to disable only "DeepGuard" module (F-Secure main user interface - Settings - DeepGuard tab and switch it off) with further try to launch game? Then, to check against "Real-time scanning".

    If trouble is still there. Then, maybe blocking is not pinned to DeepGuard or Real-time scanner (and it is an explanation why exclusion list is not workaround there).

    Then, to check "Browsing Protection" and to disable option "block harmful-rated websites". If trouble is still there - pretty strange.

    If not there - maybe certain URL / domain is blocked by F-Secure Browsing Protection and game verification is rejected at launch. If so - need to understand what is blocked domain / URL.


    Sorry for my English. And weird suggestions.



  • FrayaFraya Posts: 7
    I added the entire folder to the exclusion list and it has not helped.
    Off all the games I have from steam this is the only one I'm having this issue with.

    However UKko I disabled only deep guard as you suggested and it worked so I can play with out switching of everything. And would suggest Deep guard is the issue here.
  • UkkoUkko Posts: 2,943



    Good that, at least, it is possible to use a bit more secure workaround.


    But strange that exclusion list is not useful for situation (I thought, that recent F-Secure solutions with exclusion list for both things: scanning and DeepGuard. When item is excluded - expected that it is not analysed and is not scanned. Even it can be tricky, but probably how it is supposed to be for excluded items). Previously, there was a compatibility mode for DeepGuard (what is likely solution with such a situation) - but it is removed feature. And, probably, exclusion list is kind of replacement (more "stronger" than compatibility mode).


    Anyway, I do able to suggest contact their Support (or your ISP support - if solution is branded. Then your ISP can to escalate case by its own):


    (for example, via chat). At least, to inform about situation.




  • FrayaFraya Posts: 7

    Hi Ukko,


    I have already clicked the link in your first post and sent a message in. Am waiting to hear back on that.

  • FrayaFraya Posts: 7

    Just an update,


    Situation has not yet been resolved. still waiting to hear back

  • VilleVille Posts: 480



    I didn't see any bug report about this in beta.f-secure.com, nobody from our side has probably not even noticed this thread until now. In any case, error 51 is typically caused by DeepGuard code injection into games and some games don't like it. If we know executable to be safe, then that doesn't happen, so easiest way to solve this is submitting the game executable as false positive here: https://www.f-secure.com/en/web/labs_global/submit-a-sample. In the additional information just say that it's causing error 51 for the game with steam when DeepGuard is enabled and our labs guys will fix it.



    (F-Secure R&D)


  • WyrdBobWyrdBob Posts: 1

    Hi, thanks for posting that info about Deepguard.

    I tried adding the two exe files but no joy, then added whole ww2 folder in steamapps/common but no joy.  Then thought, 'sod it' and excluded entire steam folder and what do you know, it worked.

  • FrayaFraya Posts: 7

    Just got email from customer services. Apparently there was an option called gaming mode, after turning it on every thing works fine

  • yeoldfartyeoldfart Posts: 506

    glad for you, thanks for the info

This discussion has been closed.