My internet connection is very slow when freedome is working on iPad mini 4

Can somebody give me a solution?

since a week or two my connection is very slow when freedome is on, no matter wich server i use.

I live in Bangkok and use mostly the server in Singapore.

 

it makes no difference using 4G or wifi, it is slowslowslow all the time.

Best Answer

Answers

  • SethuSethu Posts: 519

    Hello @elias1 

     

    I would suggests you the following two steps:

     

    A) Please try clearing the cache data of Freedome app and restart your device then check again. 

     

    B) If the issue still remain, may I ask you to perform the re-installation steps?  that ensure your Freedome has been installed and running latest version.  To do so, 

     

    1.  Uninstall the F-secure Freedome.

    2. Restart your device. 

    3. Re-install the F-secure Freedome

  • elias1elias1 Posts: 12

    Voorgestelde suggesties hebben geen verbetering gebracht.

     

    het is echt een probleem dat pas onlangs optrad. Terwijl ik freedome al zo’n 2, 3 jaar gebruik. 

  • SethuSethu Posts: 519

    Hello @elias1 

     

    Could you please reply your query in English to assist you further?

  • elias1elias1 Posts: 12

    I’ve done your suggestions, without any result. 

     

    This problem occurs in the last couple of months, while i’m using Freedome for 2-3 years without much problems

     

  • SethuSethu Posts: 519

    Hello @elias1 

     

    Thank you for being a loyal cusotmer for long term, our F-secure freedome doesn't limit the speed on purpose, and the speed you're experiencing depends on a lot more than just the router.

     

    Does it happens on one particular virtual location? have you tried to change the different virtual location that closest to you? i.e  If there are many users on the same server to which you are connected then you can face a slow speed. Therefore, you should switch the servers in order to find the one which has relatively less load. Pelase have a look at this article.

     

    Also, there are certain steps you can try for slowness issue. The first thing you need to do is make sure that the problem is not your Internet connection.

     

    To check this, you need to make sure the Freedome VPN is turned off. Then you should see if your connection is still slow. You can use one of the many online network speed tests to test your connection. If your connection is slower than it should be with the Freedome VPN turned off, you may need to contact your ISP to resolve the issue.

     

    If your ISP is not the issue and your Internet is faster with Feedome VPN turned off, there are several different things you can try to boost your slow Freedome VPN connection speed:

     

    - Restart your modem and router.

    - Restart your device and check again.

    - Change the virtual lcoation server you are connected to.

     

    You can also try connecting your device with different network i.e Wifi to 4g mobile data


    If none of these improve your connection speed, you can reach our F-secure support team for further investiagation is required.

  • elias1elias1 Posts: 12

    Hi Sethu

    Thanks for the suggestions, which i’ve tried, some of them before i send a message to the community and the rest before this response.

    My conclusion is that it’s not only Freedome what makes my internet slow, but when I’m not using it, the average speed is significant higher then when using the vpn.

     

    Changing the virtual location makes difference but not much, (when it’s night there it is faster),

     

    Emptying the caches helps the speed up a little bit. Not much.

    I’ve done several speedtests, under all possible conditions, that proofed faster speed when Freedome was off.

    Remarkable was, when using server in Amsterdam, speed was higher then when i was using Singapore as vitual location. Time in Bangkok at that moment was 9:00 am.

     

    My final conclusion must be that there is not much we can do about it.

    I’ve had this problem before, but for a shorter period, that’s why i ring the bell this time.

    With in mind the thought that everything is temporarily, i have the feeling that it will be a matter of time before the problem disappears.

    When your opinion is different please let me know.

    greetings 

  • elias1elias1 Posts: 12

    As a final answer on your question: the problem did not disappear after running all the possible  solutions you’ve  suggested before.

    so there’s still work to do for the F-Secure Freedome technical department 

     

    But I repeat what i wrote before: everything is a matter of time and will loose importance more or less 

    greetings

     

  • elias1elias1 Posts: 12

    One adjustment/addition : this is not a solution because the problem still appears, I actually accept it the way it is. 

    F-Secure has still work to do by making it better than it is right now. 

  • if you are facing slow internet in your ipad mini 4 , try to clean cache of the app, and then restart it again, otherwise un-install and re-install it.

  • elias1elias1 Posts: 12

    Thanks joanne

    i did what you said but it wouldn’t be better 

  • LakshLaksh Posts: 4,424

    Hi @elias1,

     

    Just for your information, I have marked the post as not a solution as I see your issue is still not resolved.

     

    I also noticed that your post has been escalated to our support team so that they can check further on the issue. One of our agents will get in touch with you for further troubleshooting.

  • elias1elias1 Posts: 12

    Hi Laksh

    Thanks for your care. 

    At this moment I am trying  the possible solutions  provided by the support team. 

    When one of them is the right one to solve the problem I’ll very happy 

  • elias1elias1 Posts: 12

    I did that already on advice of the helpdesk

This discussion has been closed.