Installation Failed

i have facing the problem which is i have format the notebook and try to re-install back the F-secure internet security, but its shown installation Failed.


after that, i try to update windows (Windows 7 version) and try again, its also can not re-install?

(my software is Internet security 3 years, its still valid)


Any solution can suggest to me?


Thanks for advise.



  • UkkoUkko Posts: 2,960



    One option is try to use F-Secure Uninstallation Tool before further try to install F-Secure Internet Security.

    Possible to try both of them (and restart system before try to install F-Secure IS).

    Also it is good to know things like:

    -> does Windows 7 with SP1 installed already (after your tries)?

    -> with which step installation is stopped? Right after launch executable installer file? Or after some seconds/minutes of work?

    -> also does your notebook is formatted or kind of 'restore to first state'? If second option - does there any pre-installled third-party security solutions? If yes - maybe it is good option to try uninstall them not only by 'common' steps, but also with using their own specific uninstallation tools.



  • UkkoUkko Posts: 2,960


     Just as an addition and just because your topic is under Home Security Beta Programs board.

    Today I tried to install FS Protection (kind of F-Secure ISTP / beta) under Windows 7 and it was not possible to do it.

    Reason is inability to connect to certain F-Secure domain and resource.

    With my understanding - situation is not pinned to Windows 7 (and resource is not available even with Windows 10). 

    Maybe your experience is about something related to it. What if you tried to install FS Protection (rather then F-Secure IS) too; or if it is common trouble for their solutions.

    In general, I created report about it - but if it is common trouble -> such situation should be known already.


    // I found that there are some potential internal troubles with network connections (or configuration of network); so, likely that it is not a common trouble.

  • ShanePShaneP Posts: 1

    Same issue as mine but i am facing this on the latest windows 10 update 1803. dont know whats wrong.

  • UkkoUkko Posts: 2,960



    Sorry for my reply.

    @ShaneP wrote:

    Same issue as mine but i am facing this on the latest windows 10 update 1803. dont know whats wrong.

    Does it also about F-Secure Internet Security and "Installation Failed"-notification result?

    Or with some differences?



  • nanonymenanonyme Posts: 144


    This question should most likely be moved to Consumer Security/F-Secure SAFE section since this thread doesn't really concern the beta product.

  • LakshLaksh Posts: 4,428

    Thank you for the highlight, @nanonyme. I have now moved the post to the right board.

This discussion has been closed.