XFENCE on MacOS 10.31.1 Beta

Hi all,

 

Ran into an issue today after updating to the 10.13.1 beta.  Prior to each beta update, I've found that I need to export my ruleset and uninstall XFENCE, otherwise the updates don't install properly.  Not a big deal, I just restore the rules after reinstalling XFENCE.

 

Except this time.  When I tried to import the ruleset, the import button didn't respond.  I spent a while trying various methods of getting the system to respond, but to no avail.  In the end, I was finally able to get the rules to import if I unchecked any rules that were marked in red (likely because those binaries changed between the previous version of MacOS and the new one).  Once everything was unchecked, the rules imported with no problem.

Answers

  • LakshLaksh Posts: 4,426

    Hi XenoPhage,

     

    Thanks for sharing your experience. I have passed it on to the team for their inputs.

     

    Ukko
  • I also can't do software updates anymore, but here is the solution for now without uninstalling:

     

    Step 1: Temporarily disable XFence

    Step 2: Move .kext File

     

    For example move the File located at /Library/Extentions/Xfence.kext to some other place (you will need it later so don't delete it)

     

    My advice: Type this line in Terminal:

     

    sudo mv /Library/Extentions/Xfence.kext /Library/Xfence.kext

     

    Step 3: Do any updates :)

     

    Step 4: Move kext File to its original location manually or with this command:

     

    sudo mv /Library/Xfence.kext /Library/Extentions/Xfence.kext

     

    Step 5: Done

    Ukko
  • Installing updates, especially betas, doesn't seem to work when XFence is installed.  So my "solution" is to export the rules, uninstall XFence, install the updates, reinstall XFence, and finally re-import the rules.  It's kind of a pain, but it works.

     

    What I'd really love to see is some sort of an update on what the plans are with XFence.  I find it invaluable, but the complete lack of updates is concerning me.


  • @XenoPhage wrote:

    Installing updates, especially betas, doesn't seem to work when XFence is installed.  So my "solution" is to export the rules, uninstall XFence, install the updates, reinstall XFence, and finally re-import the rules.  It's kind of a pain, but it works.

     

    What I'd really love to see is some sort of an update on what the plans are with XFence.  I find it invaluable, but the complete lack of updates is concerning me.



    Can you read? I just gave you a simple solution without uninstalling?

    Ukko
  • Nope, incapable of reading. Sorry.
    Ukko

  • @XenoPhage wrote:
    Nope, incapable of reading. Sorry.

    You are the one the asked for help in the community forum

    Ukko
This discussion has been closed.