FS Protection PC Release 202

This release contains following applications that combined make the FS Protection PC product:

  • Common Component Framework 3.02.174
  • Antivirus 17.202.123
  • Browsing protection 2.202.7041

New features:

  • In case the web browser extension is not installed or enabled, the warning text on Main GUI acts as a link to open the help page with more info; in release 202, this text is always in English with an "arrow" marker shown before the text
  • On the Settings/Browser extensions page, there is a button opening the web browser on the Chrome Web Store page for installing the browser extension for Chrome; in release 202, this text of the button and its explanation are always in English with "arrow" markers shown before the texts
  • On Windows 10 Creator's Update ("Redstone 3"), Windows Defender Security Center (WDSC) will display status information of FS Protection, and the product's Main GUI can be opened from a link in WDSC

Fixed issues:

Antivirus:

  • Antivirus not unregistered from Windows Security Center (CTS-99977)
  • Software upgrade required restart, deadlock in productinfo.dll load (CTS-100011)

Browsing Protection:

  • User can add wrongly formatted address to allow list (CTS-100055, SAFE_BUG-01982)
  • Blockpage's allow button does not cause allowed page to load if url is plain http (SAFE_BUG-01945, CTS-99941)

  • Adding search site to allowed sites prevents rating icon to show (SAFE_BUG-01964, CTS-99983)

  • Network printing not working when Banking Protection is active (CTS-99942)

UkkoLord_Amibetocherockstarrocks

Comments

  • Known issues, will be fixed later

     

    "Log in" button in "My FS Protection" tab on the main UI does not work.

    The same applies My FS Protection link in Family Rules tab.

    You can open login page to your account from the task bar icon menu.

    Ukko
  • UkkoUkko Posts: 2,995 Superuser

    Hello,

     

    Thanks for release! 


    Do you will accept reports with defaced UI? :)

     

    If so: steps for repeat (at least with my system and before restart):

     

    --> open Main UI;

    --> switch to Tools-tab;

    --> choose "Scan Options/Settings"-button;

    --> with opening 'menu of abilities' (and with closing):

    we do able to see 'original' state of css-settings for colors (or contrast is off) for left/top panels.

    // just as addition: also possible to get this by 'opening' Help-menu under Tools-tab and choose any of options-strings. but more flashy.


    I also want to add that:

    ""Adding search site to allowed sites prevents rating icon to show (SAFE_BUG-01964, CTS-99983)""

    do work as fix for SAFE_BUG-01983 too (even such report is closed anyway). But looks like that it was indeed about one reason between them (or, at least, with TP202 already not possible to repeat it).

     

    Thanks!

    wayne_chen
  • VilleVille Posts: 494 F-Secure Employee

    Hi @Ukko

     

    The Halloween theme is just a beta thing, it will never be used in production, so it has some bugs related to the color inversion like you mentioned. We are not going to fix them, so no need to report them. Any bug reports not related to the colors / theme is still much appreciated.

     

    Ville

    (F-Secure R&D)

     

    betocheUkko
  • betochebetoche Posts: 49
    Oh, so its Halloween theme? why did you do that? I'm not from Europe and also I'm not interested in European Culture:)
  • UkkoUkko Posts: 2,995 Superuser

    With such situation possible to think that this is friendly deface by "Batman and the Vegetables" band (and based on their dress -> they do play something like "hardcore-punk" or maybe "glam-rock"). :)

    And they did that just for fun (and some 'tries' to re-check customization abilities with beta-solutions).

     

    But I also able to think that such situation can be strange. Even for Helsinki-based company.

  • yeoldfartyeoldfart Posts: 509 Superuser

    Dis it scare you Ukko  ?  😂

  • nanonymenanonyme Posts: 145 Active Engager

    @betoche wrote:
    Oh, so its Halloween theme? why did you do that? I'm not from Europe and also I'm not interested in European Culture:)

    Hey,

    Just nitpicking here but Halloween comes from the USA and isn't an original part of European culture

    betocheUkko
  • UkkoUkko Posts: 2,995 Superuser

    @yeoldfart wrote:

    Dis it scare you Ukko  ?  😂


    me - not. and should not. :)

  • No issues or bugs so far, except the UI bug (already mentioned). Is there any way to turn off this halloween theme?

    Edit:Grammer

    betoche
  • betochebetoche Posts: 49
    No there is not anywaySmiley Very Happy
    rockstarrocks
  • nanonymenanonyme Posts: 145 Active Engager

    Normal beta release cycle is two weeks anyway unless folks decide to roll out new theme to replace current one sooner. 

    rockstarrocks
  • UkkoUkko Posts: 2,995 Superuser

    And if they do forget to change it back / not likely :) / -- there is way to fix it locally. At least, I did it with my installation (under some of systems).

    rockstarrocks
  • May I ask how you did that? (Change the theme)

    Ukko
  • UkkoUkko Posts: 2,995 Superuser

    @rockstarrocks wrote:

    May I ask how you did that? (Change the theme)


    Yes, of course. but when I wrote that 'there is way' - I meant 'there is unofficial way' (as local temporary workaround only).

    rockstarrocks
  • UkkoUkko Posts: 2,995 Superuser

    Hello,

     

    Sorry for my reply.

     

     

    Spoiler

    Does it possible that after changes for "List of allowed/denied websites" (Allowed&Blocked sites) with current FS Protection TPs --> start be broken F-Secure SAFE stable solutions with their own (previous) design of "List of allowed/denied websites" (Allowed&Blocked sites)?

     

    What I do mean:

     

    --> Today I noticed with my F-Secure SAFE installation that there quite visible trouble with "Allowing" blockpage. And as result some other troubles.

     

    - We do able to use "Allow this website"-button (and such action put domain to allowed list), but website/domain is not allowed. And still blocked. With blockpage each try to open it. Valid with any of tried browsers.

    - We do able to place certain domain under "List of allowed/denied websites" (as allowed domain), but (as with first point) it do not overwrite blockpage;

    - We do able to place certain domain under "Denied"-part of (Allowed&Blocked websites) and save it (by close-button as with "Allowed"-part). With next opening Lists - we able to see that "Denied"-part is emptied.

    Previously added domains (before such trouble) still there and will be restricted during access with browser.

     

    --> I tried with another system as clean installation. And trouble also repeated with clean installation.

    Both systems: Windows 10 64bit (even with different builds/version of it; and with different configuration/settings).

     

    Looks like entire feature (List of allowed/denied websites) is not work (or with broken design).

     

    I able to suspect that it happened after next update:

    ""F-Secure Online Safety (64-bit) 2017-11-01_01""

    But I did not try to recheck such meanings before today (maybe it was broken days/weeks before today. And such update is not related with troubleview. Because there is topic and some other replies, where maybe potentially discussed this trouble as experience about not only one day).


    I tried to contact F-Secure Support (chat) before my experience with another system. And Support Agent wrote that it's not known as global trouble (and fsdiag is not required yet). And good to re-check 'reinstallation' as first step (for such action - I have to tweak certain things - so it was not a brief option). Then if trouble will be still there -> they has to perform remote session for collect more information/view about trouble and then will be possible to transfer fsdiag for them as required 'data' for further investigation. With greatest help of Support Agent - we tweaked certain things and it possible to try reinstallation (but I did not do it yet).

    Because I repeated such troublepoints with clean installation under another system -> I able to think that reinstallation will be not useful as fix (but I do not able to check it currently; and only created letter with such meanings to mail-discussion after the chat).

    And decided to ask there - because FS Protection works good about allow/deny websites lists (and allow-button). While such updates/modules can be common for both solutions (technology preview and stable). And I with strange feelings that it's not known trouble (?! maybe indeed something local there). Sorry for reply. @Ville  @Tuula_fs

     

     

     

    Thanks!

    rockstarrocks

  • @Ukko wrote:

    Hello,

     

    Sorry for my reply.

     

    Does it possible that after changes for "List of allowed/denied websites" (Allowed&Blocked sites) with current FS Protection TPs --> start be broken F-Secure SAFE stable solutions with their own (previous) design of "List of allowed/denied websites" (Allowed&Blocked sites)?

    ...

     

    Hello Ukko,

     

    what you have been experiencing doesn't sound very familiar, so could you please make bug reports with snapshots and fsdiags and we will investigate those issues more closely (unless you have done it already)?

     

    br,

    Tuula



    rockstarrocksUkko
  • UkkoUkko Posts: 2,995 Superuser
    Hello Ukko,
    
    what you have been experiencing doesn't sound very familiar, so could you please make bug reports with snapshots and fsdiags and we will investigate those issues more closely (unless you have done it already)?
    br,
    Tuula

     

    Hello,

     

    Thanks for response. Does it can be valid step under beta.f-secure.com - if trouble only with stable F-Secure SAFE (and not FS Protection - where all works good).

    I did contact only F-Secure Support Channel (chat) and tried to re-check with another system (than was a reason for contact Support) -> as result -> got repeat-view for trouble. // later I did receive back-reply (about my feedback for another system with clean installation) from Support with  referrence number for ability to perform remote session and other investigation (but I do not able to use this laptop quite soon). But I collected data from laptop (yesterday). @Tuula_fs 

     

    Thanks!


  • @Ukko wrote:
    Hello Ukko,
    
    what you have been experiencing doesn't sound very familiar, so could you please make bug reports with snapshots and fsdiags and we will investigate those issues more closely (unless you have done it already)?
    br,
    Tuula

     

    Hello,

     

    Thanks for response. Does it can be valid step under beta.f-secure.com - if trouble only with stable F-Secure SAFE (and not FS Protection - where all works good).

    I did contact only F-Secure Support Channel (chat) and tried to re-check with another system (than was a reason for contact Support) -> as result -> got repeat-view for trouble.

     

    Thanks!


    Hello,

     

    it is ok to use beta channel in this case, I can then forward the issue(s) in the correct place.

     

    br,

    Tuula

    Ukko
  • UkkoUkko Posts: 2,995 Superuser

    @Tuula_fswrote:

    Hello,

    it is ok to use beta channel in this case, I can then forward the issue(s) in the correct place.

    br,

    Tuula


     Did SAFE_BUG-02017 (sorry for strange explanation).

     

    Thanks.


  • @Ukko wrote:

    @Tuula_fswrote:

    Hello,

    it is ok to use beta channel in this case, I can then forward the issue(s) in the correct place.

    br,

    Tuula


     Did SAFE_BUG-02017 (sorry for strange explanation).

     

    Thanks.


    Thank you Ukko :)

    Ukko
  • UkkoUkko Posts: 2,995 Superuser

    Just as my feedback: looks like that trouble is fixed (after one of CCF updates; or with 'latest' one) on current hour already.

    nanonyme
This discussion has been closed.