Sense losing internet connection

2

Comments

  • FS_SimoFS_Simo Posts: 256

    I checked with customer care and everything should be in order also for the return arrangements.

  • Got the new sense device today, will test it out this week/weekend and report back.

    FS_Simo
  • Issue still remains....
    Reseted the fritzbox also when the new sense came.

    Currently connected via double nat.

    Sent 3 new logs via email, if the old case is still open.

    I do not know what to do next, since this issue remains with 2 different internet service providers and 2 different wan routers, cable and 4g. And also with two different computers.

    Have tried with different patch cables, tested the cables with cable tester.

    Have tried connecting directly to wan routers, no issues.

    Have tried disabling the all protections from sense and identify device as well.

    Have tried the fritzbox in bridge mode with sense.

     

    Also checked fritzbox logs and it does not lose internet connection when sense does.

    JOnes
  • JOnesJOnes Posts: 254 Explorer

    You  could try 1 month dhcp lease time(sense lan).static ip/mask/gw at the pc.Anyway the issue seems to be sense related with cable connected devices.Have  you tried eg. pinging 8.8.8.8  continuously (-t) to see if it's just dota2 which is disconnecting.

  • I have 1 month lease.

    Have not tried setting static address from pc.

    Have tried pinging 8.8.8.8.

    Well it is not just cable connected devices or dota, since the sense clearly shows the lost internet icons on the sense device when it happens as in all connected devices lose internet connection briefly.

     

    Edit: 

    I'll try next to set pc with static info and disconnect all other devices from sense and change the wlan ssid so all wifi devices wont connect either.

    JOnes
  • JOnesJOnes Posts: 254 Explorer

    Okey,symptoms are clear,sense-router is discovering the "loss of Internet".As intentionally designed to be a "sophisticated" security device for customer,technical reason(root cause) cannot be easily triggered.Possibility to run sense in "debugging mode" could be helpfull..Remarkable testing efforts though.Last test also eliminates efficiently the disconnection  if there's a "faulty" device in the sense network(s) which causes the issue.

  • Yeps but it's hard and definitely not fast to test this since i have to take my whole network down for few hours, except my pc.

    Played few games, no issues with only pc connected but still requires more testing since it also took quite long when I was testing with the 4g router, so it's basically very random and take between 10mins and 4 hours or so.

  • FS_SimoFS_Simo Posts: 256

    Apologies for your trouble. Thanks for taking the extra mile effort here, we really appreciate it.

     

    If the issue goes away when some devices are disconnected from the network it would be interesting to know what those devices are and how they are connected so we may be able to attempt to reproduce the problem.

    JOnes
  • Well....

    The issue is there still with only my pc connected to the Sense.

    Even changed the ssid so no wlan devices could not connect.

    Submitted new logs via email and mentioned in the email that those logs are with this setup.

    It seems that I need to use my wan router(s) when gaming.

    JOnes
  • JOnesJOnes Posts: 254 Explorer

    Grrr,any chance to configure the network quality "low" on the game(dota 2) side.It sends small udp/tcp packets to game-server which may burden the router in question(sense).I wonder if there's a trigger to get a full dump of the excact situation in the sense's firmware?.Anyway I think it's easier to reproduce the issue just by gaming heavily dota 2.(and sense)

  • FS_SimoFS_Simo Posts: 256

    Thanks for the information, we'll make some arrangements to test the DOTA2 scenario and see if we can reproduce the problem.

  • hepahepa Posts: 14

    Hi F-Secure,

    I installed the SENSE yesterday and see the same problem of loosing the internet connection for short or mid long intervalls. The interesting points I want to add to the discussion is that I see the connection drop only between the PC (Windows 10) computer and Internet through SENSE. If I bypass SENSE by adding annother WLAN AP I can reliably access internet with the PC. Mobile phones, printer etc etc still have a perfect connection all the way to internet while therough SENSE while at same time the PC tells me it is connected to SENSE but does not have access to Internet. The same happens when connecting to SENSE through the 5GHz band WLAN. The PC is connected using SENSE WLAN, not Ethernet LAN, just like the mobile phones.

    My setup uses the SENSE as the only WLAN AP and it is connected to Internet via a TP Link load balancing router using a 4G modem as one WAN and  an ADLS as the other WAN. The WAN connections are configured for load balancing - not backup. No clients in addition to the SENSE are connected to the LAN side of the load banacing router (except when experimenting). Four clients are connected to the  ethernet LAN ports of the SENSE while most clients are using the SENSE WLAN.

    Any idea of how to fix this?

  • So do you meant that if I connect my pc to sense via wlan, it might not lose internet connection like it does now?

    Or do you mean that I have to put another router between sense and my pc, and the connect the pc via cable or wlan to the middle router in order to not lose internets?

     

    I have some wlan usb sticks that I could try with.

  • Oh well the issue had even bigger impact with wlan since the reconnection took so long that I get disconnected from all servers (game and voip).

    With cable I usually do not get disconnected from anything.

     

    I'll try a second wlan stick just to be sure.

  • hepahepa Posts: 14

    @FormerMember wrote:

    So do you meant that if I connect my pc to sense via wlan, it might not lose internet connection like it does now?

    Or do you mean that I have to put another router between sense and my pc, and the connect the pc via cable or wlan to the middle router in order to not lose internets?

     

    I have some wlan usb sticks that I could try with.



    No, I mean that the PC remains connected to SENSE but without access to internet through SENSE. At the same time other clients, like mobile phones, still has acces to the internet through the same SENSE WLAN connection. 

  • Okay, ill try that out to be sure but i think other devices lose internet before also.

  • Well connected my laptop to the wlan and pinged 8.8.8.8.

    Then started gaming and also pinged 8.8.4.4 from my pc.

    And when the sense reported connection lost and my pc internet connection halted for few seconds as before, the laptop pinging also experienced loss.

    So anymore ideas?

  • hepahepa Posts: 14

    Now I am getting frustrated with SENSE... Also Android phones started occasionally telling me they are connected withouth Internet access. The kids PC drops has been dropping internet connection while staying connected to SENSE from start and yesterday evening I could not get an internet connection through SENSE with my work PC. Sigh. I have added annother Wifi AP to my router to use when SENSE is failing to pass traffic through but then I cannot connect to the printer nor the NAS.

  • So I am not the only one with this issue, good.

    They got my old sense back yesterday and are probably investigating it, but dunno what will they find since i have the same issues with the new one also.

    Ukko
  • hepahepa Posts: 14

    @FS_Simo Any luck in reporducing?

     

    I have an additional situation. I cannot connect my work laptop to internet through SENSE. I get connected to the SENSE wifi AP but without internet connection meaning I do not get a connection even once i a while. When I connect to a wifi AP on the WAN side of the SENSE everything works but of course I cannot connect to anything in my home. I hope you do not require a PC to have SENSE or SAFE software installed as that would totally disqualify the router.

  • FS_SimoFS_Simo Posts: 256

    We are a bit delayed with some of these cases because of the WPA2 vulnerability took most of the team to fix and verify at a fast schedule, apologies for that. This item is still on our list of things to work on. In our 'normal' test environments we don't see such break-ups so this is somehow related to some specific scenario.

     

    For your connection issue, you should not need any additional 'software' to keep SENSE running. Setting it up with the mobile app once should be enough. Did this problem start occurring after the previous update? Please provide is a bit more information about your home environment.

     

    Are you using WIFI as upstream connection? Does SENSE display the internet breakup signal (--||--)?

    Is it just your work laptop that is having the problem or other devices also? Does your work laptop have VPN running, does it help if you turn it off? If so, what specific VPN is it?

     

    Have you tried changing WIFI channels for SENSE?

    hepa
  • hepahepa Posts: 14

    Thank you for the update and ideas.

     

    I have never seen the internet breakup signal  (--||--) on the SENSE display. My work PC uses Pulse Secure VPN. Switching it on or off does not impact the lack of access to internet. No it is not only my work PC that has problems but that is the only one that has never gained access to internet through SENSE wifi AP although connecting to SENSE.  Other clients randomly looses access to internet while staying connected to SENSE and the interesing part is that they do not loose internet connection at the same time indicating it is not the connection between SENSE and the internet that is the problem.

     

    SENSE got a SW update the day before yesterday. I will do the testing again with this update. I have also now changed the channel to one that is far from any other wifi nearby. There was actually an overlap in the channels - lets hope this helps.

     

    SENSE is connected to the load balancing router by ethernet cable.

     

     

  • So your work domain pc doesn't connect to internet at all from sense.

    Does it work if your connect it directly to the wan router?

     

    So your other clients lose internet connection randomly but not at the same time? As in internet connection works for some when for some it doesn't.

     

    Since you mentioned a load balacing router, have you or can you try connections without it?

     

  • hepahepa Posts: 14

     

    This is how I tested but I have not tested with the SENSE ESW update fro the day before yeasterday:

    Connect work PC to SENSE wifi => Connected to SENSE, no internet connection while at the same time other clients do get internet connection using SENSE wifi.

    Connect work PC to annother wifi on the WAN side of SENSE => the PC gets internet connection. 

    In both cases it does not matter if I have VPN on or off in the work PC. Other clients still have internet access through SENSE.

    Reconnect work PC to SENSE wifi => Connected to SENSE, no internet connection while at the same time other clients still hav internet connection using SENSE wifi. 

    I can verify that the PC has a connection to SENSE both by looking at wifi connections (says connected, no internet) and by using a browser to access the SENSE IP adress which shows a web page asking me to install the SENSE package.

     

    Exactly: at the same time some clients get internet connection through SENSE while other do not. Seems PC computers loose the connection more often than Android phones. I have now changed the wifi channel and will follow up if this helped.

    I will make the tests bypassing the load balancing router. If that is the solution I will of course be dissappointed as the idea is to get both more speed AND reliability.

  • Try disabling sense protections one by one to see if one of them causes work pc to not have internet access.

    hepa
  • hepahepa Posts: 14

    Good idea. I will try that too during the weekend.

     

  • hepahepa Posts: 14

    Ok, now I have had a chance to test thing again.

    The internet connection works atleast right now. What has changed? - I changed the wifi channel to one as far as possible from others and the SENSE got an update. I do not know which action helped. I have reconnected SENSE to the load balancing router and the connection has remained stable for an hour or so now. I will continue to monitor the performance.

    Thank you @FS_Simo and @FormerMemberfor your ideas!

  • Back to my issue.

    After the sense fw updates my Sense does not get the internet lost icons when I experience the connection issue.

    Dunno if you guys tweaked it up on the updates.

    I'll submit new logs again by email.

    Ukko
  • Any update on this issue?

  • FS_SimoFS_Simo Posts: 256

    We have had some delays, but this is still under investigation. It is on my personal list of work items in our current development sprint. I'll update once I have any results.

This discussion has been closed.