Apple TV 4K does not work with Ethernet link

Hello,

I have an issue with Apple TV 4K and Sense router, while connecting with Ethernet.

My Apple TV detects the Ethernet link and gets an address from Sense, but there is no Internet connexion.

I’ve read a topic from 2 years ago which is very similar and seems to be fixed with a « new » firmware, but it still not work for me.

The tests I’ve made :

  • Connecting Apple TV 4K to the Sense router by WiFi : OK
  • Connecting Apple TV 4K to the Sense router with Ethernet cable : NOK
  • Connecting Apple TV 4K directly to my Internet router via Ethernet cable : OK

The problem seems to come from the Sense router. There are 6 other devices linked to the Sense router with Ethernet cables. All are OK.

Information to investigate :

  • Sense model : FSEC-SE161
  • Sense firmware : 2020-03-16_01 - p-1.10.0.750
  • Apple TV OS version : tvOS 13.4 (17L256)


Thanks for support

Answers

  • SethuSethu Posts: 638 Moderator

    Hello @Guillaume17

    Yes, we had topic here for the same issue that you have encountered now but the latest firmware was fixed the issue. However, we haven't received such case thus far in this regards. Before we check this with our backend team, would it be possible for you to try some basic troubleshoot steps.

    1. Please restart the both Sense router and Modem and unplug them before plugging them back in to see if the issue is solved.
    2. If no, may I ask you to add TCP and UDP ports for port forwarding in Sense router?

    Apple’s Home Sharing uses TCP port 3689 and UDP port 5353 to communicate with shared iTunes libraries. Additionally port 123 (TCP/UDP) has to be open to set the time automatically.

    So please find the steps in below article and add these 3689, 5353, 123 and check again.

    https://community.f-secure.com/t5/F-Secure-SENSE/How-to-set-port-forwarding-on-F/ta-p/109326

  • Guillaume17Guillaume17 Posts: 3

    Hello @Sethu,

    Thanks for your support.

    I tried step 1, it didn’t work.

    Step 2 : I have added the 3 ports, with the same value for private and public ports, and the address of the Apple TV. It didn’t work. Is that correct ?

    Do you need more information about the setup ?

  • SethuSethu Posts: 638 Moderator

    Hello @Guillaume17

    Please allow me to check this issue with our SENSE team. I will update you on the situation once I receive a response from them.

  • SethuSethu Posts: 638 Moderator

    Hello @Guillaume17

    As checked with our Sense team, there is no issue with our latest Sense firmware version and haven't received any case regarding the SENSE connection to Apple TV could not be established successfully via Ethernet.

    Trying to isolate whether the cable or one particular Ethernet port is the issue could be tried. 

    In your original post, I can see that you are saying that six devices connected by Ethernet tells that we assume so you probably have some kind of switch in between, because SENSE has only three LAN Ethernet ports.

    Would it be possible for you to connect LAN directly between Sense (port) and devices?

  • Hello @Sethu

    You are right, the Apple TV should be connected to a switch, like the other ones. But it does not work, neither via the switch, nor the Sense router.

    The cables are different in the two configurations, the Sense router ports in use too.

    I can check each Sense router port with the devices which are working properly through the switch to confirm.

    Could it be a Apple TV issue ? Could it get an address from the Sense router whithout being able to connect to the Internet ?

  • Hello @Sethu

    I tried to disconnect the switch and reboot the Sense router. In that configuration, the Apple TV got an other IP address, and it worked.

    When reconnecting the switch, one other device does not answer any more.

    While checking in the Sense app, I noticed that 2 devices have the same IP address. One is connected with Ethernet cable to the switch, the other one to WiFi. I can’t say if my issue with the Apple TV was due to the same root cause.

    Is this a known issue ? How can I proceed to avoid this ?

    Thanks for your support

  • SethuSethu Posts: 638 Moderator

    Hi @Guillaume17


    Please generate the logfile for SENSE router and contact our F-Secure Support for further investigation required.

Sign In or Register to comment.