F-Secure FREEDOME for Windows requests for reboot or fails to connect with an error message This topic explains what to do if, after the installation, FREEDOME VPN requests a restart or fails to connect.
Symptoms
After the installation, possibly after some delay, you may see the following error message:
Driver installation requires a reboot.
When you turn on FREEDOME VPN, you may see the following error message:
Sorry. Something went wrong.
Diagnosis
Sometimes FREEDOME VPN is not able to install the TAP driver it requires to work.
The reason for the errors is that something in Windows is blocking FREEDOME VPN from creating the TAP driver to the system. Probably something from Windows Update is being (or has been) installed, and Windows is pending restart.
Solution
To solve the issue:
- Click the Start menu, and enter
windows update
in the search box. - Click on Windows Update. The Windows Update window opens.
- Check if there are any updates available for your computer. If there are updates available, install them and restart the computer.
- As soon as the computer has restarted, start FREEDOME VPN and try to make a connection.
- If the problem persists, you can try to solve the issue in the following:
- Click the Start menu, and enter
command prompt
in the search box. - Right-click on Command Prompt and select Run as administrator. The Command Prompt window opens.
- Enter
control ncpa.cpl
and press Enter. The Network Connections control panel window opens. Note: Do not close the window.
- Open FREEDOME VPN and turn it on. "FreedomeVPNConnection" TAP driver should now appear in the Network Connections window, and FREEDOME VPN should work normally again.
- Close the Network Connections window.