Freedome takes long time to connect on VMWare

Highlighted
Patron

Freedome takes long time to connect on VMWare

I am running Win 10 quest on VMWare(, which is not a supported environment).

Usually I suspend the virtual machine instead of shutting it down thus avoiding the loging to all things I have open.

When I restart the VM it takes about five minutes to get connected, becaus the DNS server is not responding.

DNS_not_responding.JPG

There are the two adapters

Adapters.JPG

The configuration settings are as set during the installation

Ethernet

Ethernet_IP4.JPG

Freedome

Freedome_IP4.JPG

ipconfig shows a differnt DNS server for the Ethernet adabter

VM_ipconfig.JPG

I have added 1.1.1.1 to Freedome as it is reputed to be fast.

The DNS server on the host seems to be different with the same configuration settings

Host_ipconfig2.JPG

On the host the connection is made right after boot.

Also on the VM the connection after boot is made faster than five minutes, but lanching the programs and logging in.

 

Is there something I could do to speed up making the connection after relaunching the suspended VM.

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: Freedome takes long time to connect on VMWare

Hello @martink ,

 

Got a response from Freedome team and they said that we don't support VMWare installations as stated in my last post. This may be a case where something causes the network interface to wake up slowly after the restarting of a suspended VM. This is just a guess though, as we haven’t designed Freedome to work in a this kind of environment. However, in any case the user should NOT change the DNS address like that as it will cause problems for Freedome and will also cause some traffic to leak outside the Freedome VPN tunnel.

4 REPLIES 4
Moderator

Re: Freedome takes long time to connect on VMWare

Hello @martink 

 

Assuming, the Freedome VPN running on your physical host machine causes slow network connection after rebooted of your VMware guest OS. If yes, please try check and reduce the amount of cores in the guest OS i.e. if its 8 cores, change it as 2 or 4 cores to see if that solve the issue. Because the network performance is entirely handled by the host CPU. So you absolutely need to leave enough CPU resources for the host to do its work.

 

In addition, we do not have official support for virtual environments with Freedome. However, some configs work, while some don't, and we haven’t tested Freedome in virtual environments in such fashion that we could claim that we support some certain virtual environments.

 

May I know the Freedome version running on your physical host? so I will double check this with our Freedome team.

Patron

Re: Freedome takes long time to connect on VMWare

Thanks Sethu

 


Host Freedome version 2.27.5861.0
Guest Freedome version 2.27.5861.0

Guest number of processors 1 (msconfg boot advanced options)
Host 1

Moderator

Re: Freedome takes long time to connect on VMWare

Hello @martink ,

 

Got a response from Freedome team and they said that we don't support VMWare installations as stated in my last post. This may be a case where something causes the network interface to wake up slowly after the restarting of a suspended VM. This is just a guess though, as we haven’t designed Freedome to work in a this kind of environment. However, in any case the user should NOT change the DNS address like that as it will cause problems for Freedome and will also cause some traffic to leak outside the Freedome VPN tunnel.

Patron

Re: Freedome takes long time to connect on VMWare

Thanks.
I was aware that it is not supported.

Just wondering if there was something I could do.

Will change the DNS back as it did not seem to make any difference.

The option still is not to suspend but shut down. The downside being having to log in everywhere again.