Extremly slow speed on every Freedome server recently

Aspirant

Extremly slow speed on every Freedome server recently

Hi guys,

I'm using a 3 device licence of Freedome (2 x Windows PCs, 1 x Android Phone).
Around 2 weeks agoI made a clean Windows 7 install on one of my computers, reinstalled Freedome and updated the subscription on all devices.

Now the "new" PC has connection troubles on any Freedome server and every webpage. Sites like Google or Ebay won't load at all or display only half of the page after a minute or so. This concerns every browser.
When Freedome is deactivated there are no issues at all and I can use the whole speed of my internet connection.
The other 2 devices from the subscription work flawlessly.

Is there something I can try to fix this problem?
Thanks in advance,
Andrew

1 ACCEPTED SOLUTION

Accepted Solutions
Aspirant

Re: Extremly slow speed on every Freedome server recently

So apparently it seems to be a weird error. The support told me to change the name of the adaptor and reconnect to a Freedome server after we discussed what I already have tried. So I just added a "2" at the end of the name and a few hours later it all got better Smiley Surprised

 

6 REPLIES 6
Superuser

Re: Extremly slow speed on every Freedome server recently

Hello,

 

Sorry for my reply.

 

Just as prevention such situation (outdated topic, but sounds as your trouble's description):

 

maybe you able try to contact F-Secure Support Channel (phone/chat):

https://www.f-secure.com/en/web/home_global/contact-support

it can be available at weekends too (randomly and with unexpected hours -> so - you just able to re-check this page time to time.. if possible);


As my own unofficial temporary suggestions:

--> I not able to understand about certain connections between, but maybe good to re-check that all network drivers are up-to-dated;

OR maybe re-check that settings for FreedomeTapDriver (under your network adapters) with related view/configuration as with another system (where all good);

 

--> Re-check that installed latest (?!) Freedome build;

Maybe you also able to re-check topics under community (it was quite many about potential such situations -> some of them can be with tips about your certain stuck);

 

If all other things (like your ISP or so) still with previous state (not changed) -> most likely that it should be possible to fix/tweak something under system (?!). But maybe required additional information and research steps (what F-Secure Support able to do);

 

Thanks!

Community Manager

Re: Extremly slow speed on every Freedome server recently

Hi Andrew,

 

May I know what is the version of Freedome installed on this Windows 7 device? Did you download a fresh installer from here for the installation?

 

Have you tried to connect to a different network and check if the issue persists (may be a different Wi-Fi or data network)?

 

 

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Aspirant

Re: Extremly slow speed on every Freedome server recently

Hello guys,

 

@Ukko thanks a lot. I tried several approaches and checked the adaptors. All the drivers are up to date and I actually deleted Freedome once and installed it freshly. And it's unlikely that there's an issue with the ISP. I still have the same one as I had before reinstalling Windows and my Phone has no issues with Freedome and the ISP.

 

@Laksh The build is 1.18.3656.0 and the installer is from the official page you mention above.

So far I logged into 3 different WIfi-networks with the issue-notebook (connection speeds ranged from 32 - 100MBit).

It's as if the computer knew that there is a VPN active and forces the connection to stop working (even internet radio channels, which I stream with AIMP)

Community Manager

Re: Extremly slow speed on every Freedome server recently

Hi Andrew,

 

Since you mentioned you have already tried to uninstall and reinstall Freedome but the issue persists, may I recommend getting in touch with our support team for further troubleshooting?

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Aspirant

Re: Extremly slow speed on every Freedome server recently

Thank you @Laksh, I will do so Smiley Happy

Aspirant

Re: Extremly slow speed on every Freedome server recently

So apparently it seems to be a weird error. The support told me to change the name of the adaptor and reconnect to a Freedome server after we discussed what I already have tried. So I just added a "2" at the end of the name and a few hours later it all got better Smiley Surprised