F-Secure SAFE no longer default Anti-virus - Windows is blocking it

Novice

F-Secure SAFE no longer default Anti-virus - Windows is blocking it

I had F-Secure safe working fine on my Win 10 machine until about two weeks ago. After two Windows updates, it has decided to defualt to Defender, without asking me, and says that 'F-Secure SAFE cannot be run due to security issues'. I tried turning off Defender, and also re-installing F-Secure SAFE. I am basically blocked from using it as my default anti-virus. Freedome works fine, so I don't know what the issue is.

Anyone else had a problem with recent Windows updates?

3 REPLIES 3
Moderator

Re: F-Secure SAFE no longer default Anti-virus - Windows is blocking it

Hello @Darwyn72 

 

Have you tried to open the F-secure safe manually by double clicking the F-secure icon? Is your F-secure Safe product working?  if yes, you can try disabling the windows defender service by following the steps from this article  and to enabling the F-secure safe product as default anti-virus.

 

 

Senior Member

Re: F-Secure SAFE no longer default Anti-virus - Windows is blocking it

Hey,

Did you check from about which version of F-Secure SAFE you have? Maybe it's not updating as intended and is getting blocked as a result?

Highlighted
Aspirant

Re: F-Secure SAFE no longer default Anti-virus - Windows is blocking it

Uninstall it

Restart your computer

Login to My F-Secure, download and install it again

When updated, restart your computer once again

 

F-Secure should now be up and running fine.

 

It's important to restart the computer after uninstalling. This enable Windows Defender.

And when installed F-Secure, ALSO restart, so Windows Defender is disabled correctly and proberly.

 

New EDIT:

I had also this problem - and the Windows Update even deactivated Windows Defender, which is being used on another computer!!! :-D So, perhaps, it did that also with all other antivirusprograms - AVG, Avast!, and what we now can get....