Sense blocking Apple TV

My Apple tv (gen3) connected by ethernet to my Sense stopped working. I connected Apple support, and the Apple TV worked when it is connected to wifi to Sense, and not directly by ethernet cable. Why???? Please respond.


  • FDUFDU Posts: 57

    Strange, my Appletv is connected to sense without any problem.

    Probably, need to check again.

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee



    We have a 4th gen apple TV device here in our test environment, at least that one it seems to work fine with both cable and ethernet.


    There's been a few reports of similar scenarios for some users with other devices (works with wifi, but not with ethernet). We have not yet been able to reproduce the problem here yet. We suspect there's an issue with the DNS resolving in some scenarios. The upcoming firmware has some fixes for the DNS, with luck that helps this scenario.


    Can you please provide some extra information about your envrironment:

    1) What is your isp, router make and model (in front of sense), and connection type (cable/dsl etc..)

    2) How is SENSE connected to the internet (wifi or cable)


    Best Regards:

    Simo / SENSE QA Lead

  • Hi Simo


    here is some more information

    1. My ISP is Get in Norway

    2. The Router make in front of Sense is a Cisco EPC3010 and connected by Coax from the local vendor

    3. The Sense is connected by ethernet cable to the Cisco

    4. My smart TV, Blueray, Smart TV Decoder, Synology DSM server and my Apple TV are all connected by ethernet via a switch to one of the Sense ports. (That is my Apple Tv is now connected via wifi)

    5. All other devices than Apple TV connected by ethernet works ok

    6. I have tried other ethernet cables for the Apple TV and other ports on the switch - does not help

    7. I have connected the Apple TC directly by ethernet to the Cisco router, and it works ok

    8. I have ofcourse also restarted all devices to see if that helped - no luck


    hense - it's the Sense blocking

  • Just to check, have you tried connecting the apple tv to sense directly, without a switch in the between, with a cable from a working device?

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    Thanks for providing this information,


    Just to clarify (it was not on your list) did you try plugging the appleTV directly to one of the LAN ports of SENSE itself? Do you get the same result?

  • Hi again,


    I have now  connected the Apple TV directly to the Sense by ethernet cable, without using the switch. I get an IP address, but even so, the Apple TV will not connect to iTunes Store, and hence will not work proparly.




  • Is it possible to somehow reset the apple tv to default/factory settings and test it like that?

  • Hi all,


    I have been in contact with Apple support first, and the Apple TV has been reinstalled twice in order to verify configuration issues.

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee

    Has the situation improved at all since the previous firmware update we released last week?

  • The new firmware did not help. 

  • Email to  Mohammad Yusri September 14th.

    I really apricate that F-Secure is taking the Apple TV issue seriously.

    I have checked that the Sense has new Firmware, and I then reconnected my Apple Tv using the ethernet cable.

    The result is unfortunately the same, that is the Apple TV gets an IP address, but still cannot connect properly.
    The attached pictures shows that the Sense has new firmware and the messages on the Apple TV showing IP address and test of network.

    When the Apple TV is connected by WIFI, I have still no problems.

  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee



    It is yet unclear what is going on. So far we aren't yet able to reproduce this problem with our own equipment, but we found a colleague who has a Sonos Play:1 with a similar issue (works over wifi, not with ethernet). Hopefully we get that device here this week and can start looking into this issue if it reproduces.


    Our own Apple TV and Sonos Play:1 in our test environment work perfectly both over wifi and ethernet, so it is not a widespread problem but somehow localized to specific scenarios.


    Thanks for your patience, I'll update once we get some new information.


    Best Regards:

    Simo / SENSE QA Lead

  • Thanks for your updates!




  • FS_SimoFS_Simo Posts: 256 Former F-Secure Employee



    Took a long time to get here, but we have discovered a bug in the switch software that caused devices with certain mac addresses to fail when they were connected over ethernet.  It is probable that your issue is the same. We have released a firmware update that should address this problem, please update your SENSE and give it another try. Let us know if the Apple TV works normally over ethernet again.


    The fixed update is 2018-01-29_01 - p.

This discussion has been closed.