Uninstall XFence from macOS

XFence beta has too many bugs for me to cope with but it won't uninstall.

I managed to delete everything except 




but this refuses to be deleted.  I have tried kextunload without success.


Any suggestions?


  • Also, I tried:


    sudo rm -rf /Library/Extensions/XFENCE.kext


    but it returns "Operation not permitted"


    The extension is not active but ther ought to be a way to remove it.


    By the way, why has it become just as hard to uninstall application from macOS as it used to be from Windows?  There are so many hidden and obscure files that just clutter up one's system.

  • Ukko
    Ukko Posts: 3,527 Superuser



    Sorry for my reply. I'm only F-Secure user (their home solutions). And I'm not really friendly with Mac-platform.


    There was some topic with discussion about uninstalling F-Secure XFENCE. F-Secure Team attached XFENCE User Guide, but most likely such file or user-guide should be available with beta-portal too.

    Does it possible to re-check it? What if some useful information about this part can be there?


    Based on your "" it returns "Operation not permitted""" -> maybe file is used by system (or even protected). And maybe there should be something like Safe Mode (as it can be with Windows). Or some other steps to perform removing certain files/directories.


    Also, just interesting -> does your experience about designed uninstalling? Such as -> by expected or documented steps? And this file is placed there after?


    // if it is not possible to find XFENCE User Guide -> I will try to re-check where it was such topic.


    // later added: I mean next one topics:


    But maybe your steps are also about this (except that maybe there is certain 'recovery mode' and console-commands with partly another view; at least path with "").




  • Thank you.


    I followed the user guide's instructions but they did not work, the application remained.  I also followed the unistall steps in the thread that you attached and that didn not help either.


    The file is not being used.  The problem is nothing to do with XFence as the kernel extension for Little Flocker is also in the same folder and also canot be deleted.  So, it's really a macOS issue.


    I will post a question on the Apple macOS support community and report back if I find a solution.

  • Ukko
    Ukko Posts: 3,527 Superuser



    Thanks for your response.

    Indeed sounds as common popular trouble situation with Mac. At least, based on Google Search -> there was some of website's discussions:

    But such examples are what you already tried maybe.

    Good if macOS community will be with some good advices.


    Also, maybe with workdays -> F-Secure team may suggest something.

  • LFuser
    LFuser Posts: 6

    None of the above worked for me.  Even logged on as root user macOS will not allow the deletion of XFENCE.kext or LittleFlocker.kext.


    As far as I am concerned this problem should not be marked "Solved".

  • Ukko
    Ukko Posts: 3,527 Superuser


    As far as I am concerned this problem should not be marked "Solved".



    Just like my own feelings: if I do remember it -- I received mail notification that topic is marked as sorted by you. Maybe one of replies was chosen as sorted (randomly).

    And while trouble is 'valid' - of course - topic should not be marked as sorted. I will suggest (even if all of suggestions are not helpful) - to ask F-Secure Mac Team,@pajp. Maybe in addition to bug-report under beta-portal.

    OR maybe Community Managers with abilities to switch status of topic and re-transfer concern to related team.



  • Did you read my solution?


    Delete it from the Recovery Partition!

  • LFuser
    LFuser Posts: 6

    Yes, but I could not make it work.  Booting in Recovery mode doesn't seem to allow access to anything other that Disk Utility.  I can't see how to open Terminal.


    Anyway, the risk isn't worth the trouble.  The files are harmless and small.

  • If you really would have a problem, it wouldn't be so hard to google 2 seconds to find out how to open terminal in recovery.
    So if it isn't even worth your time to open google then I wouldn't post in this forum, because you're then just wasting other peoples time.

    In the menubar right when you boot to recovery, there is a tab called utilities

  • LFuser
    LFuser Posts: 6

    Thank you. Your solution worked for me.  A reply without sarcasm would have been sufficient.


  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hello Everyone,


    Just to keep you all posted, I have unmarked the old post (which was marked as solution) and marked the correct solution now.

  • JRG56
    JRG56 Posts: 1

    There is a bash script to uninstall XFence:


    sudo /Library/XFENCE/uninstall.sh


    Seems to delete everything - I had already followed the instructions above to delete most files before I found the script in /Library/XFENCE


  • XenoPhage
    XenoPhage Posts: 30 Contributor

    Did you try the uninstaller?




    Just disable XFENCE via the menu bar option first, run that script, and poof.  Gone.

  • XenoPhage
    XenoPhage Posts: 30 Contributor
    Wow.. i totally missed that there were two pages to this post and this was already pointed out. Apologies for the noise.
  • Bob512
    Bob512 Posts: 1

    Uninstall should not be the only option. The bug, which I was told is a design feature, is that "disable"is not persistent; that is, when you reboot it automatically reeables itself. So, if you want to set up a new Mac using Disk Target Mode you are prevented from doing the transfer because XFence has reeabled itself. Or, as others suggested, you find that the product doesn't function well enough, you should beable to persistently disable the product. This design feature is a DESIGN BUG!

  • Toweri
    Toweri Posts: 22 Explorer

    I have found a tested and working solution for those, who cannot remove XFENCE.kext from /Library/StagedExtensions/Library/Extensions/ - even via Single User mode:

    Delete the actual kext from /Library/Extensions/ first, then run "KextWizard" (downloadable at https://mac.softpedia.com/get/Utilities/Kext-Wizard.shtml) and enable both checkmarks under "System/Library/Extension, i.e. "Repair permission" and Rebuild cache" - then click "Execute".

    This removes the stubborn XFENCE.kext from the cache (that /Library/StagedExtensions/Library/Extensions/ actually is) and keeps it from being activated over and over again.

  • Mac OS is great. And I also used it which don't create any bug problem and also if you interested in it then you will do one thing that is just getting some review, which will be good for all. And also if you want to do this which you told then you will do one thing just print the important which you have. Also, I have epson scanner driver

This discussion has been closed.

📢F-Secure Quiz Challenge📢

Join our online quiz session on June 15th, 2023, at 11:00 AM EEST and stand a chance to win prizes.