Sense Speedtest differences

Hi,

I did run KPN’s  Speedtest from the same PC directly connected to my provider's router (Fritzbox 7390) and next connected to the F-Secure Sense.

I have an synchronous fiber connection of 100Mps, which is limited to 80 Mbps on the download site.

 

Results maximum download speed without Sense: 79 Mbps, with Sense 52 Mbps, difference -/- 34%

Results maximum upload speed without Sense: 93 Mbps, with Sense 20Mbps, difference -/- 78%.

 

I read that the Sense should not show too much performance penalty, due to packet inspection, up to 300Mbps.

Any comments on these results?

Comments

  • aadmunaadmun Posts: 20

    Addition: all connections between the devices based on 1 Gbps UTP, no WiFi used.

  • 1sknew1sknew Posts: 12

    Well speedtests are not the most reliable and you should do like 10+ and get an average of the results.

    Also use the html5/beta version http://beta.speedtest.net/

     

    I have found that for example downloading a big game from Steam is the best way to know if your connection can reach as high as advertised.

  • aadmunaadmun Posts: 20

    The quality of the speedtest is not the concern.

    It has been run several times because I could not believe my eyes.

    The issue is the limited throughput of the Sense device!

  • 1sknew1sknew Posts: 12

    Ok, I did not notice any difference really with my cable fritzbox and 250/20 connection, but my Sense had other issues so I'll do more testing when I get the new device.

     

    Do you have the Sense's LAN port on your fritzbox in bridge mode?

    Or have set the connection for it as unlimited/nonrestricted?

  • aadmunaadmun Posts: 20

    A Fritzbox in bridge mode does not work with a Sense because the Sense does not support the PPPoE protocol.

    I can't image that with the standard settings the Fritzbox 1 Gbps LAN-ports are limited in speed.

     

    Any other tips to improve the Sense's throughput are welcome.

     

     

  • 1sknew1sknew Posts: 12

    I got my new Sense and tested this out.

    Speedtest gives basically the same results as it would normally.

    Steam downloads at 240-260 (24-26 MB/s) as in at maximum.

    Also in my country they do not promise the max speed 24/7 for home networks (only business).

     

    But I do not know about your case, isn't that fritzbox meant for adsl connection and not fiber?

    Fritz!Box 7390 ADSL2+ modem/router

    https://www.pcworld.idg.com.au/review/fritz_box/7390/389484/

    Ukko
  • aadmunaadmun Posts: 20

    Hi 1sknew,

     

    I doubt if you do the same test as I have done. Connect a PC directly to your Fritzbox and do the Speedtest. Next connect the Sense to the 1 Gbps port of Fritzbox with a UTP cable and connect the PC directly to the Sense. Rerun Speedtest.

    I Like to know the results for down- and  upload. 

     

     

    Ukko
  • LakshLaksh Posts: 4,435 Community Manager

    Hi aadmun,

     

    If you have a 100 Mbps internet connectivity speed and the SENSE box is connected to your home router via a gigabit Ethernet connection, then there should be practically no difference in speedtest with SENSE or without SENSE.

     

    One test case you may still try: In your SENSE app, turn off all protection features and see if speedtest would give you any different scores.

    Remember to turn the protection features back on after the test.

  • aadmunaadmun Posts: 20

    Hi Laksh,

     

    I did retest the provider’s download and uplink speeds via Sense with Protection off. However results are the same:

     

    Download drops from max. 79 to 52 Mbps and the upload from max. 93 to max. 20 Mbps. The PC is a HP Compaq 8100 Elite SFF with an Intel 82578DM Gigabit Network Controller.

    Providers link is 80 Mbps download and 100 Mbps upload.

     

    I repeated the test with an Compaq Studio XPS PC.

    The dramatic degradation of throughput does not show up at this system!

    Download 79 Mbps via provider router and Sense.

    Upload 77 Mbps via provider router and 71 Mbps via Sense.

     

    I did the test with an Asus laptop.

    Download via 1Gbps UTP around 50 Mbps and upload around 18 Mbps via provider router and Sense.

    Download via Wifi 5G around 50 Mbps and upload around 17 Mbps via Sense. Provider router does not support 5G.

    Limited throughput possibly caused by limitations of the laptop.

     

    I reran the test with an iPhone 6.

    Download via Wifi 5G around 80 Mbps and upload around 90 Mbps via Sense. Provider router does not support 5G.

    So no degradation of Internet speeds with iPhone via 5G Wifi and Sense.

     

    So left over is the dramatic performance loss with the HP Compaq 8100 if connected via Sense!

    Any ideas?

     

    Is there someone else who has the same experience with one of his systems? If yes, is there an solution available? Thanks.

  • Download latest NIC drivers, uninstall current ones and install the latest ones.

    Check NIC driver settings for things like green ethernet and power saving. Also try to set it manually to 1000 full duplex.

    Try the different browsers.

    Set pc's general power profile to full performance.

    Possibly shutdown all other programs, including antivirus.

    Boot to safe mode with networking and test speedtest.

    Also full reset of windows10 might be a good way to test a clean install of the OS.

     

    Test after/between all different settings/steps.

     

    Edit:

    Also here's HP's guide on debugging slow speeds.

    https://support.hp.com/id-en/document/c03460887

     

  • aadmunaadmun Posts: 20

    Hi 1sk,

    Thanks fort the tips. But why should I do all this while this PC, if directly connected to the provider router, shows excellent down- and upload speeds (close to the line speeds)!

     

    Only if connected via the Sense to the router, the down- and upload speeds drop significantly.

     

    As far as I can determine there is nothing wrong with that PC. Possibly the Ethernet protocol handling is different. If no input comes from other Sense users, I will check differences with a protocol analyzer.

  • Well as long as I have worked on this field I have come to realize two simple things:

    1. Never take anything for granted. For example "I know it cant be this" "I know this works 100%", these are the failure points in debugging.

    2. Anything can cause problems, even the weirdest things that you find out accidentally or something that you never do.

     

    But sure it's your problem and you can debug it as you like. Most of my suggestions take 5-15mins at most to test out.

  • LakshLaksh Posts: 4,435 Community Manager

    Hi aadmun,

     

    Based on your test with the iPhone, we can say that the SENSE performance is not the issue. So we suspect something in the connectivity.

    Your HP Compaq 8100 works fine with your home router. Then again, SENSE works fine with the Compaq Studio. So it’s really hard to say.

     

    First double checking:

    - Both the upstream link (router <-> SENSE) and the downstream link (SENSE <-> PC) are cable?

    - Are both cables of high quality and working fine? (was the Compaq Studio tested with the same cables?)

     

    We had a case in the SENSE team with a broken cable. It was not completely broken but it cut the throughput significantly.

    Can you please test it with cables that proven to be good?

  • aadmunaadmun Posts: 20

    Hi Laksh,

     

    Double check answers:

    - All connections are 1 Gbps UTP based between Home Router and Sense and between Sense and Workstations

    - The UTP-cable from Sense to the HP Compaq has been replaced. However the same results.

     

    I will backup the image of the HP Compaq and do a clean install and will see what the results are.

     

    In the meantime I made Wireshark captures of the Speedtest with a connection to the Home router and one via the Sense.  Analysis will take some time.

  • aadmunaadmun Posts: 20

    Hi 1sk and Laksh,

     

    Herewith the results of the tips of 1sk:

    1) NIC Driver = Intel 11.6.92.0 dated 2010-04-12

    Checked for driver update with PROWinx64.exe –> no driver update available for Intel 82578DM and Windows 10; only the adapter settings menu has changed with more options

    2) Green Ethernet setting not available

    All Power Save options were already disabled

    Speed was already set to 1.0 Gbps Full Duplex

    3) Same results with Edge, Firefox and Chrome

    4) F-Secure Sense antivirus disabled; no change

    5) Boot with safe mode and networking active; no change

    6) New fresh clean install of Windows 10 with Local account and no additional apps and data; no improvement! NIC driver is still Intel 11.6.92.0, after reinstall.

     

    So still throughput degradation with Speedtest from ~80 to ~50 MBps on Downloads if HP Compaq 8100 connected first to Home Fritzbox Router and next to Sense and ~85 to ~20 Mbps on Uploads.

     

    Peculiar issue! Hope the Wireshark TCP/IP captures will tell more.

  • aadmunaadmun Posts: 20

    Results of the protocol analysis:

     

    KPN’s Speedtest servers use the IP6 (Fallback IP4) TCP/IP Protocol stack in combination with the WebSocket protocol.

    Both of my PC-systems do reach a throughput close to link speeds with a direct connection to my Provider’s Router. The Dell Studio XPS does the same via the F-Secure Sense.

     

    My HP Compaq 8100 is the only one showing dramatically limited throughput via the Sense. The WireShark capture shows that the TCP/IP protocol is forced to IP4, instead of IP6 on the Dell, and it is struggling with the communication.

     

    I found another test server, Google’s Speedtest which is offered in combination with M-Lab, offering Internet Speedtests based on TCP/IP 4 only.

    Checking the throughput on all my PC’s do not show measurable limitation of the speed via the Sense.

     

    I checked with Ziggo, another Internet service provider. They also offer a Speedtest based on IP4 (not IP6) with WebSocket. Also in this case no limitation on speed via the Sense!

     

    I checked with ipv6-test.com and found out that IP6 from my HP Compaq via the Sense is Not Supported (score 4 out of 20)!

    With the HP Compaq directly connected to the Provider Router it reports IP6 is Supported (score 17 out of 20)!

     

    Conclusion:

    The combination F-Secure Sense with an HP Compaq 8100/Intel 82578DM NIC shows a compatibility issue on the IP6 protocol.

     

    Other users of the Sense, who measure limitation of throughput via the Sense, are advised to check their network speed via more than one Speedtest provider.

    Use ipv6-test.com to check IP6 support.

  • Sounds interesting and I think you actually found a bug or something, but of course that's a very old device too, 7 years.

  • aadmunaadmun Posts: 20

    The HP Compaq 8100 is an older device but, at this very moment, still resold as refurbished units. It was a popular and speedy PC within companies.

  • Popular yes, speedy not. Mainly used in some factory workstations and applications which require 2-4gb total ram with win7.

  • LakshLaksh Posts: 4,435 Community Manager

    Hi aadmun,

     

    I have forwarded your findings to the SENSE team. I will get back to you if there is any new update on this.

    aadmun
This discussion has been closed.