Cannot access sense settings from app if sense router does not have internet access




I noticed a pretty weird problem as it seems that I cannot access sense settings from the app if sense router does not have internet access. But I can connect to the wlan, but it shows on the android's wlan settings as "Connected, no internet access".

So if I do something wrong when configuring my sense network settings, which cause the sense to lose internet connection, i cannot revert back without performing hard reset.

Why does sense require internet connection for allowing me to connecto to the configuration with the app if I am connected to the sense's wlan?



  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee



    Thanks for getting in touch,


    This should not be the case, as long as the app can connect to SENSE it should be able to control it. The only exception is that the app or the gadget has been reset and the pairing has been lost. In that case, you need to reset both SENSE and the app and run the setup again.


    The soft reset _should_ work as long as the device has booted and is running normally (hold reset button for 15+ seconds and let go, rSt shows on screen and device boots normally). Also please let me know if that is not the case.


    Can you elaborate what settings exactly are you trying to configure and how and perhaps elaborate how that relates to your other networks if applicable (are you trying to set them to the same subnet by chance?) There is a possibility that configuration somehow breaks the connectivity between the SENSE device and the Android phone or that we have an actual bug.


    Please also let us know which phone / os version you use?


    Best Regards:

    Simo Punnonen / SENSE QA Lead

  • Unknown

    Ok, well the app could not connect to it and I did not reset the app until I had reseted the Sense.


    Well I think I then just perfomed a soft reset, since I initiated reset just like that, but that also resets all the settings and pairings.


    Yes I actually tried to configure the Sense to an existing subnet on my network.


    I currently have double nat if i understood right, since it would seem that I need to modify/hack my CableInternet modem/router to get the bridge options available.

    My old network is:, dhcp, modem's ip/gw: 

    Sense network is:, dhcp, Sense's ip:

    Sense WAN settings (dchp on):, gw, dns


    So first I tried to change sense's network to:

    Sense's ip address:, dhcp (as in to the same subnet as my old network)

    Sense WAN settings:, gw, dns


    Next I tried just to manually change the Sense's WAN setting IP address to a manually configured one, but it also lost connection then.

    Sense WAN settings(dhcp off):, gw, dns

    Untouched Sense network is:, dhcp, Sense's ip:


    My phone is: Oneplus3, android 7.1.1, oxygenOS 4.1.6.


  • Unknown

    Yeps this is a user error, at least the configuring both on the same subnet.

    Are there some downsides on not having the wan router in bridge mode? Expect like in things like portfowarding where I think I have to foward ports 2 times. From device on sense and from sense on the modem to internet.

  • F6
    F6 Posts: 53 Enthusiast

    I have tried both (Wan in bridge and not), absolutly no difference, except the port forwarding.

    But this point is useless for me: as Android user, I can't forward anything with Sense !


  • F6
    F6 Posts: 53 Enthusiast

    At least Sense should not allow to set colliding subnet on both interfaces.

This discussion has been closed.