Where to find the WPA 2 key?

I've got a new TV an tried to connet it wireless to the Internet. I was asked to fill in the WPA2 key, but haven't been able to see, where to find the WPA 2 key.

I tried the password from F-secure SENSE, but the TV only accept letters and numbers and not special caracters.

 

Answers

  • JaimsJaims Posts: 416 Moderator

    Hi @ErlingM 

     

    Do you mean you want to connect your TV to the WiFi network and it's requesting for the WiFi password?

     

    You just need to enter the WiFi password from F-Secure SENSE and if there is no option for special characters, then we suggest you change your password to accommodate alphabets and numbers only. That should work. 

  • ErlingMErlingM Posts: 6

    Thx for answering. 

    I was not aware, that the automatic generated password could be changed. But I'll try.

    And I've informed the TV manufacturer (one of my clients) about the problem with security level: F-secure (and I!) want a high level, the TV just want to make it easy for the users and therefore the special characters and not used.

     

  • ErlingMErlingM Posts: 6

    It took a while - but now I've tried to follow your advise - but it doesn't work:

    When I change the password to the net work in the SENSE app to a new one without special characters, I press Save and the OK to the warning.

    But the password will automatically go back to the one, the system have created.

    Back to start so to speak - and I still can't get my Smart TV on the internet, which leave it as a non-Smart TV!

  • JaimsJaims Posts: 416 Moderator

    Hi @ErlingM

    Since apologies for the late response.

    Fist, could you please let us know the exact error message on the TV?

    Secondly, am I right to say that this issue sufficed only on the Smart TV and other devices can connect via WiFi?

    Have you tested connecting to the main router or via wired to SENSE without any issue? We would like to confirm if the issue is only via WiFi. You may also try to change your SENSE WiFi password to 16+ characters and see if that helps.

  • ErlingMErlingM Posts: 6

    Sorry for my delay in answering!

    I have no problem with other devices than the Smart TV. When I try to connect the TV to the Internet, I'm asked for the WPA/WPA2 Key. I'm not aware, where to find it?

    I've used the password generated in the SENSE Router app but the message on the TV screen says, that it's an invalide key with a wrong length: should be between 8 and 63 characters.

    The problem according to Philips TV is, that F-secure have a stronger password policy and the Smart TV only accept letters and numbers. I tried to change the password into a new only with letters and numbers in the SENSE Router app, but it switch back to the auto generated password.

    I also tried to use the password to the Huawei router = bypassing SENSE. But the same problem accured.

    As I see it, the problem is, that I can't find the WPA2 key.

  • JaimsJaims Posts: 416 Moderator

    Hi @ErlingM

    Thanks for your response.

    It would be interesting to see if simple password like "password12345" could be configured successfully.

    Different Smart TV brands may have different connection types but the settings should allow for a custom method so you can change the settings and allow your SSID.

    You might want to further check for the custom option in setup network connection and then adjust the Network & Wireless setting then try to change the Security type. You can try each of the settings from None, WEP, WPA/WPA2... until you find the one that works for you or try using a direct connection considering the proximity between SENSE and the Smart TV.

  • ErlingMErlingM Posts: 6

    Thx for quick answering. I'll give it a try as suggested with the simple password.

    But I still see the kay issue is the WPA2 Key for the SENSE router. I've had a lot of routers, and they all have the WPA/WPA2 key printet on a label on the back side of the router or on a label in the box.

    For the SENSE router I can't see the WPA key; neither on the router, in the box, in the manual or on your web site.

  • ErlingMErlingM Posts: 6

    Find a simple and quick solution instead of using the unknown WPA/WPA2 key: I bypassed the SENSE router and connected the TV set with the Huawei router via the WPS button. Could'n find a WPS button on the SENSE router.

    So now the TV is on the Internet; but unfortunately not with the optimal security.

    I still think, F-secure should take a closer look at the connection of Smart TV's.

    Thx for your kind help.

Sign In or Register to comment.