Not sending SMTP email from GoDaddy email account

Highlighted
Scholar

Not sending SMTP email from GoDaddy email account

I cannot get email from my godaddy email account if Freedome is turned on. Nor will it allow me to change ports with vpn on. 

I have reinstalled Freedome several times, searched your community response pages and tried all the suggestions but it will not work if vpn is on. 

My iPhone email outgoing configuration:

smtpout.secureserver.net

SSL on

Server port 80 or 465

after several extensive sessions with godaddy, running diagnostics and setting changes, they said since it works fine with vpn off but not with it in, it is not their issue. 

So how are you going to fix this problem?

7 REPLIES 7
Moderator

Re: Not sending SMTP email from GoDaddy email account

Hello @WPB27 

 

Did you see this KB article before trying to change SMTP port? if yes, but the issue still reproduce, we need to make sure the email blocking issue that is occured only with your email service provider. Would it be possible for you to try check with different email service provider? i.e Gmail

 

 

Scholar

Re: Not sending SMTP email from GoDaddy email account

Yes, I had read the article. As per godaddy, I changed 465 and 80 with SSL and 3535 and 25 with SAL off—or on. The later to were rejected by Apple settings. 

If I disabled vpn, I could set both 465 and 80. With vpn on, iPhone would hang until I rebooted the app. 

Botg 465 and 80 would send email with vpn off. 

I have 4 different email accounts on this iPhone:

1 icloud

1 outlook 

1 business Microsoft account

godaddy

 

all other accounts work perfectly 

 

Moderator

Re: Not sending SMTP email from GoDaddy email account

Hello @WPB27 

 

Thank you for your confirmation and since your other email's services are working as normal. So I am afraid that the SMTP port needs to be corrected.  Assuming, that you are using the iOS Mail app on your device and tried the steps from this go-daddy KB article.

 

So you can try change option for using SSL and Server Port as recommended one by one as below

 

Use SSL: On

Server Port: 25 or 465 or 587

 

You can then do restart your iphone for the changes to take effect, and to see if that solve the issue. 

 

Scholar

Re: Not sending SMTP email from GoDaddy email account

Thank you. 

587 finally worked. I appreciate your help

Scholar

Re: Not sending SMTP email from GoDaddy email account

After spending 2 weeks testing and working thru with support to get my godaddy email account to work with Freedome, it worked for about 3 days and now even port 587 will no longer allow me to send emails with vpn on. 

I think the time has come to ask for a refund, as I cannot waste any more time making this program work.

Scholar

Re: Not sending SMTP email from GoDaddy email account

In answer to you last question, 587 worked for 3 days and now does not work any more when vpn enabled.  I have spent countless hours searching thru your files, following your instructions and providing detailed replies. But bottom line, as of 9pm, Saturday May 18, 2019, Freedome VPN does not work for my primary business email.  

THIS IS TOTALLY UNACCEPTABLE. 

 

PLEASE CANCEL MY SUBSCRIPTION AND PROVIDE A REFUND.

Moderator

Re: Not sending SMTP email from GoDaddy email account

Hello @WPB27 

 

SMTP default port 25, but it may happen to be blocked by your ISP. This is something we need to analysis the logfile in order to further check. However, you can contact our F-Secure Support for further investigation or refund.