Freedome: "Error initiating VPN connection"


Freedome: "Error initiating VPN connection"

Thought I might share this:

I'm running Freedome on iOS 8.1.3 (12B466), iPhone 6+. 


Already had been using Freedome for a while. Today, after starting Freedome app, was asked by app to delete VPN profile due to "known bug". After deleted profile, and new certificate was installed, error message as follows:


"Error initiating VPN connection

Could not turn on VPN. Try again later or try another location. 

If you encounter this issue repeatedly, please visit our support forum"


Error prevailed through both cellular data, corporate and home WIFI. Tried several times to delete profile and add new certificate, without luck.

Solution: purge app - reboot phone - reinstall app - add new certificate. Now works fine.



F-Secure Product Expert
F-Secure Product Expert

Re: Freedome: "Error initiating VPN connection"

Hello Chjdome,


Thank you for keeping us updated on the resolution, and glad it is now working again.

Best Regards



Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.