F-Secure Computer Protection/Server Protection installation on Windows host fails between 80 to 99%

Issue:

I am trying to install F-Secure Computer Protection/Server Protection on a Windows host and it failed between 80 to 99%.

In fsdiag, NetworkInstaller.log displays the following entry:

*E: MsiMessageCallback: MSI: Service 'F-Secure Hoster (Restricted)' (fsnethoster) failed to start.  Verify that you have sufficient privileges to start system services.
*E: MsiHandler::RunMsi: MSI returned code 1603

Resolution:

Follow the workaround below to fix the installation issue:

  1. Rename following files to anything else (e.g. vcruntime140_old.dll):
  • On 64 bit Windows: 
    • C:\Windows\SysWOW64\vcruntime140.dll
    • C:\Windows\SysWOW64\msvcp140.dll
  • On 32 bit Windows:
    • C:\Windows\System32\vcruntime140.dll
    • C:\Windows\System32\msvcp140.dll
  1. ​​Restart the host.

If the steps above do not help, there is a possibility that registry key HKEY_USERS\S-1-5-20 doesn't have the required permission for NETWORK SERVICE and fsnethoster is unable to create an entry there.

Follow the steps below to fix the issue:
  1. Click Start.
  2. Type regedit, and press Enter.
  3. Navigate to and select registry key HKEY_USERS\S-1-5-20.
  4. Select Edit.
  5. Select Permissions.
  6. Click Add...
  7. Type NETWORK SERVICE.
  8. Click Check Names (the name should get underlined).
  9. Click OK.
  10. Check Allow checkbox for Full Control (also Read permission should be automatically allowed).
  11. Click Apply.
  12. Click OK.

Article no: 000002638

Pricing & Product Info

For product info and pricing please go to the F-Secure product page

Version history
Revision #:
3 of 3
Last update:
3 weeks ago
Updated by: