Computer Protection 19.2 will introduce .NET

F-Secure

Computer Protection 19.2 will introduce .NET

Dear Partners and Customers,

 

as we are preparing for the Computer Protection 19.2 release, it is time to give you a heads up on something that we've been working very hard on. The new release for the first time will include a dependency to Microsoft .Net as a technology for our future user interfaces in the clients.

 

What this means for you in practice for updates:

  • If you have .NET 4.7.2 already on  your computers, updating the product through the channel is just as it was before.
  • If you have an operating system that supports .NET 4.7.2, we will install the version as part of the installation. Reboot is only needed if something is using .Net when installation starts. We will not prompt for the reboot, but it will be visible in the Downloads list as "Reboot required". You will stay in 19.1 version until the reboot and the product continues receiving updates.
  • If you have an operating system version that does not support .NET 4.7.2 (some early Win10 versions have been dropped from support by Microsoft), you will need to update your operating system to move on from 19.1 version. You will see this in the Downloads list as "Will try again".

What this means in practice for new installations:

  • If you have .NET 4.7.2 already on  your computers, installing the product is just as it was before.
  • If you don't have .NET 4.7.2, it will be installed and installation has a little more work to do to get you started.

As part of PSB service, we will be monitoring the progress of the installations and upgrade throughout the installed base.

 

The availability will start this week, and we'll be posting release notes as usual on the contents. This is just adding a bit of understanding on what is changing.

 

On behalf of the PSB Windows Endpoints R&D team,

     Maaret

 

1 ACCEPTED SOLUTION

Accepted Solutions
F-Secure

Re: Computer Protection 19.2 will introduce .NET

Here's instructions on how to fix the computer - this issue you're experiencing on .NET is specific to Windows 8.1 / Windows Server 2012 R2. https://medium.com/@what_if/net-framework-4-7-2-install-error-0x80092004-cannot-find-object-or-prope...

 

You also identified a problem we are fixing at F-Secure. The retry happens with one of our calls to backend every six hours, and that is not our intended behavior.

 

Support will update the case, I don't have access to leaving you a personal note there.

 

     Maaret

11 REPLIES 11
Highlighted
Superuser

Re: Computer Protection 19.2 will introduce .NET

Hello,

 

I can also report that "PSB One Client 4.02 build 1067" fails to install on my fully Microsoft Updated "Windows 8.1 Pro 64-bit" laptop. During repeated installation attempts the laptop makes a lot of cooling fan noise due to high CPU load. Because of the above situation "FSAV PSB CP 19.1 Premium, One Client 4.01 build 168" remains in use as of now.

 

Best Regards: Tamas Feher.

F-Secure

Re: Computer Protection 19.2 will introduce .NET

Hi,

 

would you be able to pass us a F-Secure Diagnostic file so that we can resolve the issue there?

 

Thank you in advance,

    Maaret

Superuser

Re: Computer Protection 19.2 will introduce .NET

Dear Maaret,

 

.NET 4.72 installation failed with error code: (0x00000476)
ERROR_TOO_MANY_LINKS (attempt was made to create more links than the OS supports).

 

Please revoce the FSAV PSB CP version 19.2 immediately! It is unacceptable that so many computers are running at CPU full throttle, attempting to install .NET again and again at every hour, in complete vain! Those computers may as well mine crypto-coins as that would be the same with regards to wasting electricity and over-stressing electronic components with protracted 100% CPU load.

 

I also cannot accept that F-Secure is basing anti-virus security on something as fragile as .NET! F-Secure products already cannot protect against ransomware, because the hindi hackers come in through remote access and turn off F-Secure services and processes, which do not protect themselves with a password against unloading, unlike Kaspersky. Thus encryption of files can then happen undisturbed. Now F-Secure is further weakening itself by relying on a fragile and often changing Microsoft technology.

 

Considering that .NET is used for nothing but to display the "About" screen in PSB CP 19.2, it is ridiculous that F-Secure caused all these problem just to introduce it. I am now thinking about switching to Sophos after 18 years, due to the .NET snafu and the high false malware alarm rate seen with F-Secure DeepGuard and the Avira Capricorn scan engine.

 

Best Regards: Tamas Feher, Hungary.

F-Secure

Re: Computer Protection 19.2 will introduce .NET

Hi Tamas, 

 

being one of the people who are facing this problem, I understand you feel frustrated with it. We're looking into what we can do. The 100% CPU load is not what we're measuring on checking on .NET, so we know we are learning more from what you are experiencing now that what we've seen before. We could fix the problem with seeing a diagnostic tool output. My direct email is maaret.pyhajarvi@f-secure.com if that would help in delivering it to us.

 

On the reasons of why moving to .NET makes sense for user interface components, you can look at how our user interface on the clients has not changed in the years we've introduced new relevant protection. While the about screen makes little sense as the reason of introducing .NET, the new settings in progress and coming out in future releases should make more sense. 

 

I hope that with your 18 years of experience with us, you will be able to trust in our ability to take things forward for you.

 

     Maaret

Superuser

Re: Computer Protection 19.2 will introduce .NET

Dear Maaret,

 

Thanks for your quick response! I have submitted an FSDIAG as support case number xxxx.

 

From a broader perspective I find the situation highly problematic as the mandatory F-Secure PSB channel upgrades are supposed to start today (March 11th) on a daily 10% conversion basis, but many computers which are still on PSB WKS 12.01 won't be able to migrate to PSB CP 19.2 due to the dotNET snafu.

 

Thus F-Secure Corp. has created a big problem for itself, conservating a large number of endpoints on the old platform, possibly for months and likely requiring manual intervention to fix them.

(If F-Secure Corp. had let CP 19.1 in place in the channel until the PSB WKS 12 pool fully migrates, those computers would have been able to adopt the dotNET-less product successfully and already be on the new generation protection platform.)

 

Yours Sincerely: Tamas Feher, Hungary.

 

EDIT: Removed Case number

F-Secure

Re: Computer Protection 19.2 will introduce .NET

Hi Tamas,

 

we have been working on the mandatory migrations today, and from migration of profiles, it still takes two weeks more before the subscriptions will be picked up for being upgraded on the endpoint protection. We have also tested scenarios around this .NET change with moving from WKS12, and have done a lot to ensure we would not have a wide-scale problem there.

 

Unlike with WKS12 products, with Computer Protection generation of clients, we can see statistics over the whole installed base of devices. As much as we hate to cause you any inconvenience and trouble, we are continuously monitoring the scale of problems our new mechanisms enable us to see, without making compromises on privacy which we hold to very high value. This generation of end point protection enables service level - support level - we were not able to reach before. We need to change our protection mechanisms, to keep stepping up in protection with the rate of change the malware industry is introducing.

 

I'm delighted to realize we have very similar considerations. We got you diagnostic file, thank you, which can enable us to further react with fixes in the two week period. We're responding you through the ticket as soon as we have a resolution. I still wanted to thank you for helping us with this.

 

       Maaret

F-Secure

Re: Computer Protection 19.2 will introduce .NET

Here's instructions on how to fix the computer - this issue you're experiencing on .NET is specific to Windows 8.1 / Windows Server 2012 R2. https://medium.com/@what_if/net-framework-4-7-2-install-error-0x80092004-cannot-find-object-or-prope...

 

You also identified a problem we are fixing at F-Secure. The retry happens with one of our calls to backend every six hours, and that is not our intended behavior.

 

Support will update the case, I don't have access to leaving you a personal note there.

 

     Maaret

Superuser

Re: Computer Protection 19.2 will introduce .NET

Dear Maaret,

 

Thank you! Using your instructions I was able to fix the .NET pre-requisite on my notebook, so it received PSB CP19.2 eventually.

 

On the other hand, I feel the same manual process would be too complicated for un-attended PSB locations and many F-Secure home-user customers, who are now also receiving new FSIS versions with the .NET pre-requisite condition. For example, I had to do the .NET reset process twice with reboot to succeed and the website's description says some people had to repeat it 3x times to be effective.

 

I feel F-Secure needs to find some automatic remediation for those customers who have problems with .NET v4.72 not installing on their computers. Especially since the minimum version requirement of .NET is likely to increase in the future, so the problem could emerge again and again! F-Secure's ethos has always been about automation and un-obstrusive operation, so the current situation is rather unfortunate.

 

Thanks in advance, Yours Sincerely:

Tamas Feher, Hungary.

F-Secure

Re: Computer Protection 19.2 will introduce .NET

Tamas,I'm glad we helped you.

We have selected .Net as our future development platform across products and introduced it in this release with minimal set of features which use it. Already starting from next release more components will use .Net.

This release is definitely the most painful one - for us and for customers. We are gathering statistics and we will know soon how many upgrades fail and for which reason. We expect amount of failures and not supported systems to be below several percent but still - we will see how the rest of clients can be upgraded.