Strange behaviour from Banking Protection

Superuser

Strange behaviour from Banking Protection

Since the last update, I've noticed some 'different' behaviour from Banking Protection, and I'm not sure it's a 'feature' or a bug.

I use Router Stats to monitor my connection and router SNR, and what happens is, when Banking Protection is started, the Router Stats tray icon goes red and displays '0' as my SNR, presumably because BP has isolated the connection to the site I'm using. When I come off that site, and BP is closed, the Router Stats icon turns green again, and displays my SNR again. I don't think the SNR part is relevent to this, but by turning green, the icon indicates that the connection is back to normal.

However, since the last FSP upgrade, the Router Stats icon doesn't turn back to green when I exit Banking Protection. I can still access websites in this status, but other connections, such as torrents, remain blocked.

So, for some reason, Banking Protection is not fully 'releasing' when it is closed, and the connection doesn't run properly again until I reboot the computer. Has anyone else noticed this?
8 REPLIES 8
Superuser

Re: Strange behaviour from Banking Protection

Hello,

 

Maybe around my experience was something same. I not sure.. that I totally normal understand your steps for repeat. But... commonly situation looks like... can be related with my experience.
But my experience will be with next description and points:

 

-> Google Chrome (Blink-core) and (?!) maybe Firefox too... after banking session (not always?! maybe, but there with my experience.. each "time" have various funny points around - so I not check it more, than fifteen minutes).... goes to be stuck with "banking protection" pop-up after a closing browser.

Such as.. I mean: I close browser... and pop-up does not missing (after some seconds/minutes).

And it's looks like.. that there goes mistake with fshoster-process. I not check.. about "manually" "end session" before closing browser or other. I think it's can be related with any of stuck browser's processing (or with my experience there can be "slow connection", slow machine and other).

 

Potentially with Internet Explorer was all OK. But.. there was another strange points. So I just create a "freeze" for dreams about it.

 

Does you can to re-check your points.. with various browsers (if you check it with alternative one and not check with Internet Explorer as example)?

Superuser

Re: Strange behaviour from Banking Protection

Yes, I will check with other browsers.
Superuser

Re: Strange behaviour from Banking Protection

Hello,

 

Also.. I think... maybe with your situation... another point, which not really related with Banking Protection. But related with "certain" software.

Such as... what if you able to check.. how also will be situation, when feature about "cut established network connection during BP" will be disabled (such as.... check "does not restrict active network connection" under Banking Protection settings). If it will be normal... maybe just current software (torrent-client as example) not able to "trigger" re-loading for connection.

 

Such as... it's not possible to re-connect/re-load/re-fresh by software mechanism, but F-Secure also can not to trigger something for "reloading/reconnection" for certain software. Or maybe software able to re-connect, but just after time-point (hour, two hours or other). And restart just as "trigger"-point for them. It's maybe can be something else. For restart services or connection.

 

Because.. with my situation.. I also have next point: when "the situation" comes (it's not always, but steps can be visible around some of not common ones or with some background) stuck about next trigger for Banking Protection. Such as it's not possible to get pop-up again.. or simply.. start be available to visit malicious pages or Banking protection "ignored" (it's can be triggered) - but does not restrict something. Such as.. when host-process not work or not loaded yet.

Superuser

Re: Strange behaviour from Banking Protection

I don't think it's anything to do with torrent software not 'reconnecting', as the connection should always be there anyway. I think BP is perhaps not unblocking a part of the connection, for example, TCP / UDP, etc, but I don't know enough about networking to make a judgement on that.

Ah, I've just thought of something. Isn't there a new option not to disable active connections when BP is triggered? Maybe I need to look at that?
Superuser

Re: Strange behaviour from Banking Protection

There another meanings:

-> How I can to understand:

--> there was always feature about "blocking" connection during Banking Protection (with probably limitation around some of points.. and with trusted connection, which allowed).

--> now.. it also comes with "blocking" active connection, which was established before Banking session.

Such as not just NEW one, but "active one" prevented too. Paused/stopped/restricted/cut-action/something else.

It's probably also work with limitation and with some of "trusted" connection - which will be allowed. Or how it can be called "safe"-connection (which marked as "safe" for F-Secure).

 

-> It's mean.. there have option under Browsing Protection - Banking Protection with checkbox about "does not cut active network connection, when BP started". Such as new one will be still blocked, but "current" not restricted (if it's does not create new one ?! string). Or something else.

 

Maybe you can to check about situations with current setting (there uncheck-status by default should be, but possible to check it).

 

But anyway... maybe there should be talk with F-Secure people. Or with people, who can be a technician, developer or other people, who friendly with technologies.

It was just my suggestion (such as.. active connection was "stopped" - but how software can to understand.. that it's already can be normally work.. if it's not triggered under software). But maybe there indeed a stuck around BP. :)

Superuser

Re: Strange behaviour from Banking Protection

Well, I tried that option, and strangely, torrents are now working, but the Router Stats icon is still red.  dunno.gif

Superuser

Re: Strange behaviour from Banking Protection

Someone should to say for Router Stats... that he already can to use network :)

Highlighted
Superuser

Re: Strange behaviour from Banking Protection

Router Stats has now bounced back into life as well!  I'm guessing now that this must be a time delay thing.  Probably best to wait for @Ville  or someone else form the beta team to comment on Monday.  :)