F-secure BETA website cannot be access

Senior Advisor

F-secure BETA website cannot be access

Hi All,

 

I can't seems to access to Beta F-secure website. It gives a DNS Error.

I did not have a clue as to what had happen to the site. 

 

 

18 REPLIES 18
Superuser

Re: F-secure BETA website cannot be access

Hello,

 

Maybe, it is only temporary misconfiguration (or kind of it) for certain instance. But, I do able to recommend "do not visit the beta portal" on current time. Just for sure.

At least, situation sounds strange. There is a redirect(?!) with some forms (certain circumstance).

// edited later: some claims are removed. since unsupported by anything.

 

Good to receive an official attention from F-Secure. Or an explanation about.

Although, inability to use website under HTTPS is pretty and good mitigation (probably).

Senior Advisor

Re: F-secure BETA website cannot be access

Hi

 

Today Beta F-Secure site is totally down again. 

Superuser

Re: F-secure BETA website cannot be access


@Rusli wrote:

Hi

Today Beta F-Secure site is totally down again


// remark: I am only an F-Secure user (their home solutions).

 

I think this is during all week (occasionally). I am not sure about any proper "descriptions", but my own unofficial feelings are:

- beta portal (domain) with two instances ('provided' by third party service).

- one instance with discussed trouble; another one is safe.

- if you hit "wrong" instance, then portal is inaccessible due troubles with certificate (mismatch OR invalid cert /later/).

Perhaps, server is configured to return "certain" instance for certain location or user (based on something). Something as balancing.

Or instances are switching between each other time to time. As a result, based on who is primary - website is accessible or not.

 

I tried to contact Support (one week before), but discussion got stuck then during letter discussion (probably, based on my worst explanations and wordings). And then "silence" for some days (after I tried to provide a bit more clear sentences and suggestions about reasons / situations).

 

Thanks!

Superuser

Re: F-secure BETA website cannot be access

Sorry for the feedback and over-the-reply.

Sounds that today situation is fixed. Beta portal should be accessible and "safe". Although I did not receive any confirmations of it; only my own feelings.

Senior Advisor

Re: F-secure BETA website cannot be access

Hi

 

I cannot access to the F-Secure BETA site to due this error .... 

This site can’t be reached

beta.f-secure.com took too long to respond.

Try:
ERR_CONNECTION_TIMED_OUT
Check your internet connection.

Check any cables and reboot any routers, modems, or other network devices you may be using.

Allow Opera to access the network in your firewall or antivirus settings.

 

Superuser

Re: F-secure BETA website cannot be access


@Rusli wrote:

 

I cannot access to the F-Secure BETA site to due this error .... 

This site can’t be reached


Hello,

 

It is my experience too. Website is not accessible. Sounds that it is a general trouble (not pinned to something on user's side) with server. Maybe something with configuration. Smiley Sad

But, apparently, it is another situation compared to original topic concern.

 

Thanks!

Superuser

Re: F-secure BETA website cannot be access

This is a real pain!  I uninstalled FS to test a couple of other AV products (needless to say, which didn't come up to scratch), but now I can't access the beta portal to reinstall FS, so I've no security!

Superuser

Re: F-secure BETA website cannot be access

Well, I managed to find the installation file for when I installed FS on my laptop a few months ago, so I used that on my PC and am now protected again.

 

Out of curiosity, I tried BitDefender and Kaspersky, and both fell short.  Bitdefender's banking protection doesn't work with my browser, and KIS produced a prompt for every website I wanted to visit, which I had to click to add as an exception.  Couldn't have any of that!

Highlighted
F-Secure

Re: F-secure BETA website cannot be access

Are you getting "403 Forbidden"? If so, clearing the browser cache helps.