Safe browsing extension for Firefox 57++

0 Likes

Safe browsing extension for Firefox 57++

The old addon isn't working any more and me and a lot of other people are waiting for a respective safe browsing extension for Firefox (57) Quantum...

 

AFAIK a browser extension as required by Mozilla now can be used for all browsers in the future, so F-Secure basically only needs to develop one extension with minor adaptions for other browsers. Quantum's release date had been announced with due notice.

1 Comment
Superuser

Hello,

 

Sorry for my potential feedback (I'm only F-Secure user).

 

Looks like that it should work already. and updated Browsing Protection extension is available for Mac/Windows.

 

Thanks!