There is no internet connection on my PC when F-Secure Freedome is ON

Issue:

Why there is no internet connection when Freedome is turned on?.

Resolution:

Try to reset the DNS cache on your devices.

For Windows:
Open the command prompt as an administrator. Click the Windows start button > type "cmd" > Right-click Command Prompt > Click Run as Administrator.

In the Command prompt, type the commands below. After each command, press Enter to execute.

  1. ipconfig /flushdns
  2. netsh winsock reset
  3. netsh int ipv6 reset

You can restart your machine and check again.

If the above steps do not help, the issue might be that your firewall is blocking the connection.
If that is the case, you need to change your firewall settings to allow the connection.

Our Android, Windows and macOS products use the OpenVPN protocol.
The ports for Android, Mac, and Windows are:
  • TCP/UDP ports in the range 2700 - 2800
  • TCP port 443
Please allow traffic on these ports in your firewall and try to connect Freedome again. 
Refer to this video on how to open Windows Firewall and configure the ports: https://www.tomshardware.com/news/how-to-open-firewall-ports-in-windows-10,36451.html

Please check if automatic killswitch is enabled. Here's how to check.
  1. Open Freedome
  2. Click Settings
The automatic killswitch is the 4th button under Connection & Status. If it is turned on,
  1. Click Allow connections to other devices in trusted networks
  2. Check the network you're currently connected to
  3. Click Save
User-added image
 

Article no: 000006587

Pricing & Product Info

For product info and pricing please go to the F-Secure Freedome product page

Version history
Revision #:
93 of 93
Last update:
‎09-10-2019 01:08 PM
Updated by:
 
Labels (3)