My F-Secure FREEDOME subscription code does not work

Symptoms

Note: This article applies to you only if you have a standalone version of the F-Secure FREEDOME product.

You have bought an F-Secure FREEDOME subscription. When you enter the subscription code in the FREEDOME app, the app does not accept it.

Diagnosis

As there are several types of purchasable subscription codes for F-Secure FREEDOME, there are a number of reasons why your code may not work:
  • You may already have a purchased FREEDOME subscription, and you are trying to renew the subscription with a promotional code.
  • Your free 5-day FREEDOME trial has come to an end, and you are trying to extend the trial with a promotional code.
  • You have a multi-platform subscription and all the licenses with that subscription are already in use.

Solution

To solve the issue, do the following:

  1. If you already have a purchased FREEDOME subscription, you cannot renew the subscription with a promotional code. To renew your subscription, you have to buy a valid subscription code.
  2. If your subscription is a multi-device subscription, release a license by doing a license transfer.
Pricing & Product Info

For product info and pricing please go to the F-Secure Freedome product page

Version history
Revision #:
3 of 3
Last update:
‎11-10-2019 07:07 AM
Updated by:
 
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