Installation on Google Pixel XL / Android 9

Highlighted
Scholar

Installation on Google Pixel XL / Android 9

Hello,

 

I have Google Pixel XL device with Android 9 on board. And I can not install F-Secure FREEDOME VPN product as far as it marked as "This app is incompatible with all of your devices."

 

Why my Google's flagship device is not supported there?

 

Thank You

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: Installation on Google Pixel XL / Android 9

Hello @PFil85 

 

F-secure Freedome does support Android 5.0 and later.  Sometime the playstore cache could causes the issue.  So please try clearing the Google Play Store cache, and then data. You should then restart the Google Play Store and try installing the Freedome app again. 

 

For instance,  close the Play Store and  go to Settings > Apps > Google Play Store > Clear Data and Cache  

 

In addition, "This app is incompatible with all of your devices."  does not necessarily mean that your device's technical capabilities are incompatible with the Freedome app. While that may often be the case, it can also refer to geo-restrictions that the Freedome app has set. Our Freedome is available selected countries listed in this link, and if you happen to live in a country that the Freedome app is not (yet) released in, you too will receive the incompatibility message.

 

 

1 REPLY 1
Moderator

Re: Installation on Google Pixel XL / Android 9

Hello @PFil85 

 

F-secure Freedome does support Android 5.0 and later.  Sometime the playstore cache could causes the issue.  So please try clearing the Google Play Store cache, and then data. You should then restart the Google Play Store and try installing the Freedome app again. 

 

For instance,  close the Play Store and  go to Settings > Apps > Google Play Store > Clear Data and Cache  

 

In addition, "This app is incompatible with all of your devices."  does not necessarily mean that your device's technical capabilities are incompatible with the Freedome app. While that may often be the case, it can also refer to geo-restrictions that the Freedome app has set. Our Freedome is available selected countries listed in this link, and if you happen to live in a country that the Freedome app is not (yet) released in, you too will receive the incompatibility message.