I cannot select the "I trust this application" checkbox in F-Secure FREEDOME VPN. What can I do?

Symptoms

I am unable to select the "I trust this application" checkbox in the FREEDOME app.

Diagnosis

This issue is related to other apps masking the checkbox dialog in FREEDOME; for example, apps, such as Lux Brightness, Night Mode, or Twilight are known to cause these issues.

This dialog appears after first-time installation or reboot.

Solution

If you run into this issue:

  1. Close any apps that may be running in the background.
  2. Select the I trust this application checkbox, then select OK.
Pricing & Product Info

For product info and pricing please go to the F-Secure Freedome product page

Version history
Revision #:
9 of 9
Last update:
a week ago
Updated by:
 
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