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I bought F-Secure FREEDOME through Apple AppStore or Google Play, but cannot install it on my other devices

Symptoms

I bought F-Secure FREEDOME through Apple AppStore or Google Play, but cannot install it on my other devices.

Diagnosis

If you have bought or purchased FREEDOME from the Apple AppStore or Google Play, the subscriptions are limited to one operating system, but are valid on all your iOS or Android devices connected to the same Apple ID or Google account.

Solution

If you have a valid, auto-renewable app store subscription and want to upgrade to a multi-platform subscription, you need to cancel your app store subscription first.

Read the following app store-specific instructions on how to cancel a subscription:

Note: Even though the subscription is cancelled, the auto-renewable app store subscription remains valid until the end of the original subscription period. You will not be able to activate your multi-platform subscription code yet (see Grace periods with F-Secure subcriptions). Once the subscription expires, FREEDOME notifies you, and you can enter your personal subscription code that you received from the F-Secure eStore provider.

Pricing & Product Info

For product info and pricing please go to the F-Secure Freedome product page

Version history
Revision #:
3 of 3
Last update:
a month ago
Updated by: