Freedome on mac does not connect, but does on iPhone.

Scholar

Freedome on mac does not connect, but does on iPhone.

I have F-Secure FREEDOME on my mac and iphone, I am using a public wifi network that requires a log in and probably blocks proxy ports, but the iOS version of FREEDOME seems to connect fine, whilst the Mac OS version just spins reading 'connecting' without any progress.

 

I connect to the wifi network without FREEDOME on in order to log in to the service, but then cannot connect FREEDOME on the mac, but can on the iphone.

 

Is there any way that I can configure the mac OS version of FREEDOME to connect on this network? The iOS version seems to connect with ease, and surely it is possible to replicate this on the mac OS.

 

Many thanks,

Jon

3 REPLIES 3
Community Manager

Re: Freedome on mac does not connect, but does on iPhone.

Hi Jon,

 

Have you tried to connect to a different network using your Mac and iPhone and see if the Mac works in a different network?

 

Freedome for iOS uses a different VPN standard (IPSec) than the other OS as mentioned in this article. Freedome for Mac uses OpenVPN protocol as mentioned in this article.

 

My guess is that the admin of that Wi-Fi network might have blocked the other VPN protocol through the network as mentioned in this article here.

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Scholar

Re: Freedome on mac does not connect, but does on iPhone.

Laksh,

 

The mac and iphone both work on other networks, I suspect that you are correct in terms of OpenVPN being blocked on this particular network.  I have previosuly read all of these articles, but I cannot change the setup of the router / network. Is there any way that i can use another protocol from my mac?

 

 

Community Manager

Re: Freedome on mac does not connect, but does on iPhone.

Hi Jon13,

 

The options as of now is to use a different network for the Mac or request the Wi-Fi provider to allow the VPN protocol.

 

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.