Freedome not working with WLAN, only 3G (iOS7.1.2)

Scholar

Freedome not working with WLAN, only 3G (iOS7.1.2)

As title says; Freedome is not working with WLAN, it doesn't enable, and always suggests to reinstall certificate. It works fine with 3G though. I created a video and submitted it to F-Secure via Support request (F-Secure Customer Care: 00301877), but they redirected me to this newsgroup. Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Scholar

Re: Freedome not working with WLAN, only 3G (iOS7.1.2)

The problem never disappeared. But in the meantime I upgraded to iPhone 6 and iOS8. As you replied today, I tried again with the new device. Same problem. But the new error message was very helpful. I had to enable IPSec Passthrough on my router. Now it's working with WLAN too. I did also get the "rare iOS8 upgrade issue, please reboot" error, but rebooting solved that. If you look at my original video, that might also give you a feedback about user experience.
6 REPLIES 6
Former F-Secure Employee

Re: Freedome not working with WLAN, only 3G (iOS7.1.2)

I'm sorry for the delay with our response.

 

If you are still suffering from the problem, we would like to look into it in more detail. Please let me know if this is still valid.

 

Thanks,

Päivi

Scholar

Re: Freedome not working with WLAN, only 3G (iOS7.1.2)

The problem never disappeared. But in the meantime I upgraded to iPhone 6 and iOS8. As you replied today, I tried again with the new device. Same problem. But the new error message was very helpful. I had to enable IPSec Passthrough on my router. Now it's working with WLAN too. I did also get the "rare iOS8 upgrade issue, please reboot" error, but rebooting solved that. If you look at my original video, that might also give you a feedback about user experience.
Former F-Secure Employee

Re: Freedome not working with WLAN, only 3G (iOS7.1.2)

Great to hear that everything works now. And thank you for letting us know.

 

I ask for the video from our support team.

 

Thanks,

Päivi

Novice

Re: Freedome not working with WLAN, only 3G (iOS7.1.2)

I have a time warner cable 100mbit account, they just replaced my router with a Technicolor router, IPSec passthrough is enabled, but now freedoms does not work. Just on mobile data.
Always worked before upgrade to technicolor router. But only thing I find is the IPSec pass through and its enabled.
Free some tells me to restart phone bc ios8 problem, but problem not resolved and freedoms works fine with 3G but as soon as I connect to technicolor router; no internet. Also internet works perfect on router when not in freedome.
Help!
Novice

Re: Freedome not working with WLAN, only 3G (iOS7.1.2)

Technicolor tc8715d
Highlighted
Senior Member

Re: Freedome not working with WLAN, only 3G (iOS7.1.2)

Could you screen shot the error and send to us?

You may have a corrupt VPN profile.

Remove the profile from settings > general > profiles

Make sure Safari is allowing JavaScript.

Settings > Safari > Advanced > Check JavaScript and try again.

Check for updates for Freedome and your iOS device.

Run Freedome and reinstall the profile.

If you are still having issues you may need to unisntall and reinstall Freedome.