Freedome does not work with latest windows 10 update!

Aspirant

Freedome does not work with latest windows 10 update!

protection offAfter updating to latest windows 10 version 10.0.16299.19

Freedome Tap Driver no longer works -> Connect button does nothing.

Tried to reinstall -> no help

 

Please make new update asap!tap driver

1 ACCEPTED SOLUTION

Accepted Solutions
Aspirant

Re: Freedome does not work with latest windows 10 update!

Found solution!

i downloaded latest version of Openvpn and it got needed tap driver update.

Now freedome connects!

4 REPLIES 4
Aspirant

Re: Freedome does not work with latest windows 10 update!

Found solution!

i downloaded latest version of Openvpn and it got needed tap driver update.

Now freedome connects!

Community Manager

Re: Freedome does not work with latest windows 10 update!

Thanks for sharing your solution, Snakeee554! Glad to know Freedome connects again.

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Novice

Re: Freedome does not work with latest windows 10 update!

My Freedome stopped also working after Windows 10 Creators Fall update, pressing "Protection" button just flashes "On" and returns to "Off".

 

No offence, but are you serious that this bug report is set to "Solved" state on based that random user was able to fix the problem by installing some third party software?
How have you verified that that third party SW that you basically recommend to install is safe to install?
Is F-Secure acknowleding this bug or does it rely that users install third party SW to fix F-Secure SW bugs? Based on "Solved" state, it looks like F-Secure doesn't even see any problem?

I though that F-Secure is security focused company...

Superuser

Re: Freedome does not work with latest windows 10 update!


BNo1 wrote:

My Freedome stopped also working after Windows 10 Creators Fall update, pressing "Protection" button just flashes "On" and returns to "Off".

No offence, but are you serious that this bug report is set to "Solved" state on based that random user was able to fix the problem by installing some third party software?
How have you verified that that third party SW that you basically recommend to install is safe to install?
Is F-Secure acknowleding this bug or does it rely that users install third party SW to fix F-Secure SW bugs? Based on "Solved" state, it looks like F-Secure doesn't even see any problem?
I though that F-Secure is security focused company...


Hello,

 

Sorry for my reply.

I'm also only F-Secure user (their home solutions) and not an official F-Secure staff.

 

But just as some my own unofficial suggestions and feelings:

 

-- technically this topic is not a bug-report (but can be part of this).

Because this is Community - where users able to ask something and someone able to try help. If trouble is sorted (for this one who asked)  -> quite nice to say 'good that you sort it' (generally -> Community Managers are supposed for such things).

But I also with feelings that good if official F-Secure Staff did 'transfer' or 'ask' by internal channels about this situation. As communication with F-Secure Freedome team (when trouble is appeared not a first time).

So, possible to see "sorted topic" (even if required proper investigation later).

 

-- for 'sure' that trouble is handled by F-Secure Freedome Team (or even more - with investigation): I able to think that good to contact direct F-Secure Support Channels (chat as example):

https://www.f-secure.com/en/web/home_global/contact-support

and it will be already more as 'bug-report'. And maybe such situation still under investigation (if someone did report/contact support... and if it was not known for Freedome team). As explanation that there is not visible any notifications/fresh builds/fix-step's articles about recent Upgrade/Freedome situation.

 

-- based on my own experience with such Windows 10 Update and Freedome: all works good after it.

Freedome still works.

Previously there was kind of 'related' trouble with system update/upgrade -> when was changes with driver signature verification (if I remember good). 

 

-- with recent topics was some suggestions about potential fix-steps (which not works based on feedback). But Freedome Knowledgebase article also with next article:

https://community.f-secure.com/t5/F-Secure/Network-connection-issue-with/ta-p/85331

as potential try-step (from official resources).

 

But good if official statement from F-Secure Staff comes here.

 

Sorry for my reply. Smiley Sad

 

Thanks!