Sense: Nov 3 firmware update blocked several devices

Novice

Sense: Nov 3 firmware update blocked several devices

Hi

 

it seems that a Sense firmware update on Nov 3 caused a couple of my IoT devices to be blocked from accessing the internet. They worked fine with Sense before and continue to work fine if Sense is not the router but I replace it with a Netgear router. 

 

The devices affected are

- a Netatmo weather station

- a ThereGate z-wave gateway (Fortum Fiksu)

- a d-link webcam

 

at the same time, A Philips cloud camera continued to work fine with Sense, for instance.

 

There were no threat reports in the Sense log files and the issues seem to be directly related to the Nov 3 firmware update.

4 REPLIES 4
Former F-Secure Employee

Re: Sense: Nov 3 firmware update blocked several devices

Thanks for the report, there were very few changes in the update on november 3rd, we practically reverted some more extensive changes we had done earlier that may have been a source of some reported issues.

 

How are the devices 'blocked'?

Do you get a block event in the threats list or do they  just fail to connect over wifi / cable?

Are they failing to get IP addresses?

 

Does restarting SENSE help?

If the connection issues are WIFI related, could changing the WIFI channel used by SENSE help?

Former F-Secure Employee

Re: Sense: Nov 3 firmware update blocked several devices

Also, please check from the devices list that the "block internet" switches are off for those devices? Does flipping them on/off help?

Aspirant

Re: Sense: Nov 3 firmware update blocked several devices

My Netatmo weather station works fine with Sense Nov 3 firmware update.

Regular Member

Re: Sense: Nov 3 firmware update blocked several devices

I have a similar problem.  Recently SENSE started to block configuration network traffic of my zipatobox (Zwave controller). Normal traffic to the cloud still works fine, this problem is restricted to cases whre I modify the devices or rulesets in my controller and then sych it to the cloud.  After trying unsuccessfully various port forwarding and whitelisting options I reported this problem to F-secure and they are investigating the issue.

I also dicovered few workarounds:

 

1) Turn off the SENSE protection when updating zipatobox configuration - this allows me to tweak the automation rules.

 

2) Connect the Zipatobox to SENSE via another router. Ealier I have connected my Zipatobox to SENSE via Ethernet port. However, if I connect another wlan router to SENSE and then connect my zipatobox to the ethernet port of this router, I do not have any problems.