installation failed


Re: installation failed

That's a shame. I've bumped the thread so maybe someone will come back to it.

But I seem to recall there was a thread in which an F-Secure Expert commented, and it was something to do with matching the device name. Maybe I've been here too long and dreamt it! Smiley Very Happy

Re: installation failed

i have windows xp professional version 2002 service pack 2  with 504 of ram. 2.39 GHz  2,40GHz


i downloaded the program but it wont let me install.  it says my current version of windows is not supported,  on the supports page it doesnt state what service pack i need.


Re: installation failed

You need SP3 (Service Pack 3) What "version 2002" means I don't know. I guess you mean Office version.


In case you haven't noticed: Microsoft is dropping its support and security updates for Windows XP in april 2014. So you might wanna get a newer PC. Just an advice.

Former F-Secure Employee

Re: installation failed

Hello All,


To me it looks like there are a couple of different problems reported so far to this thread (and at least some have found a working solution already.)


So - if there's still somebody there who hasn't been able to install F-Secure on their computer(s) - I'd advice to open a support ticket at:


It will the best course of action at this point, as we'll be able to gather also logs from the affected computers to make sure we can avoid installation issues like these in the future.




Re: installation failed

Hello.  I too am having continuing difficulties with the installation of F-Secure, necessitated by the (imposed) change over from VirginMedia.  I have been through the process and yesterday sought some help from a local IT expert, since my attempts to contact customer support have so far been useless - no response.  I hope that I shall now find that this method is indeed the quickest way of getting an answer, and resolving the problem.

I am assured by the IT expert that the system has been installed, and is indeed running in the background.  However, every time I switch the machine on I am prompted to enter a subscription key, and this is repeatedly rejected - so I get the 'Installation failed' message.  My machine is the second in our household upon which we have been trying to install F-Secure. After considerable difficulty, my husband [the main account holder] has managed to install it successfully on his machine. We have 5 licences available, and so are using only 1 at present; and, as directed,  I have been using the same subscription key as he used when successful.

Are there particular problems related to the registration/validation of more than one machine?  We are sure that we have followed the correct procedure, which has been time-consuming,so this is now becoming very tedious.  I look forward to a rapid response.

Community Manager

Re: installation failed

Hello Mola,


Hope this response is rapid enough :)

We're sorry you're having problems getting in touch with our customer care team.

I can assure you, this is not the normal situation. We're currently very busy, due to the holiday season.


Could you please visit the SAFE portal (
Once you logged in, please click "install" next to Internet Security and follow the instructions, download and run the installation.


There is no need for any subscription keys anymore, the portal will take care of all that stuff.


Could you please let us know if this solved your issue?


Best regards,

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.

Re: installation failed

Hello Stephan.  Thank you for your prompt response, but sadly I'm still in the same position, after following the instructions as advised: there seemed to be no problem with the download and installation (indeed, as I said before, it had appeared that I had in fact already succeeded in that).  But even after switching the machine off and re-starting it, still I am being reqested to type in a subscription key.

Do you have more ideas about how I can eliminate that please?


Re: installation failed

When you download and install from the SAFE portal there should be no prompt for a subscription key! So something is wrong here.


- I suggest you un-install the product from your machine using Windows Control Panel, Programs and Features.

- Then run the Uninstallation Tool 

- Read the PS section below

- Reboot

- Then log in to the SAFE portal and remove your machine from the list of installed devices. If it does not appear there, I guess you haven't installed through the SAFE portal (which would explain why it asks for a subscription key)

- Then in the Internet Security section in the SAFE portal, click Install and follow the instructions.


PS. Some customers coming from Virgin Media Security have had strange problems with F-Secures product because VMS haven't been completely removed for some reason. If you haven't already run the additional VMS removal tool, read this post under the heading "Removing Virgin Media Security".

Give Kudos to say "thanks". Click "Accept as Solution" to inform others when your issue's been solved
Need more help? Submit a Support Request or chat / call F-Secure support

Re: installation failed

Thanks for trying, NikK.  We have already uninstalled and installed again - maybe we are indeed missing something, but it seems very strange that there have been no such problems with the installation onto my husband's machine.

Right now the frustration levels are too high to attempt anything else!  And I would still appreciate a further response from Stephan too (presumably tomorrow) as I do think that the F-Secure customer support isn't great at the moment (and i do realise that there may be reasons for this); but I'm certainly not getting what I've paid for at the moment!



Re: installation failed

I see, but maybe you can answer these quick questions (your answers may help us help you better):


When you log in to SAFE, do you see both your computers in "Your Devices" at the bottom of the page?

Do you have different OS - Windows/Mac versions?