fsgk32.exe eating away CPU cycles doing nothing?

Aspirant

Re: fsgk32.exe eating away CPU cycles doing nothing?

Yes, turning DeepGuard off/on also stops fsgk32.exe from its constant 9% CPU churn immediately as well.

F-Secure Product Expert

Re: fsgk32.exe eating away CPU cycles doing nothing?

Hi cvax,

 

Please try to keep the DeepGuard ON but turn OFF the APM.

- Settings> Computer > DeepGuard.- Clear the Use advanced process monitoring check box.

 

Best regards,

Jayson

 

"A person who never made a mistake never tried anything new" -Albert Einstein

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Aspirant

Re: fsgk32.exe eating away CPU cycles doing nothing?

Hi Jayson,

 

Thank you for the response. I will try that later tonight when I get a little time to play.

Curious, what exactly do I lose in terms of protection with APM off? Thanks.

Aspirant

Re: fsgk32.exe eating away CPU cycles doing nothing?

Jayson,

 

I can confirm that with APM off, after leaving Battlefield 3 while leaving Origin open, the result is instead of fsgk32.exe taking up 9% CPU I now have FSHDLL32.exe taking up 5% and fsgk32.exe taking up 4-5% constantly.

 

Again, cycling on/off DeepGuard or just turning off Origin stops the waste of CPU.

 

I will now try adding Punkbuster to my exclude list.

 

Edit: Looks like excluding PnkBstrB.exe solves it as well. So it is very clear now that F-Secure just does not play well here with Punkbuster. Can the tech guys at F-Secure look into why?

 

Workarounds:

1. Turn off Origin which in turn would kill the PnkBstrB.exe application

2. Exclude PnkBstrB.exe from real-time scanning

3. Power cycle DeepGuard off/on to get it to stop scanning PnkBstrB.exe