cancel
Showing results for 
Search instead for 
Did you mean: 

Why won't F-Secure let MetaTrader work

Aspirant

Why won't F-Secure let MetaTrader work

Metatrader (MT4) users currently cannot run their application if F-Secure/SuperSafe is active.

 

They receive a terminal.exe "intialisation error 4". This doesnot happen when F-Secure is deactivated

 

This has been documented in a no. of places e.g. here

 

SO my question is, WHEN WILL THIS ISSUE BE FIXED??

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
F-Secure

Re: Why won't F-Secure let MetaTrader work

Hi @Lawrence

 

When our product blocks something because it's malware or suspicious, it will always show a flyer or dialog about it. In this scenario I couldn't see such flyer, so we are not actually blocking anything. The problem is on Metatrader side, usually caused by some integrity check or copy protection that reacts to DeepGuard.

 

You can check if this is the problem by going to our main UI > Settings > DeepGuard and enable "compatibility mode". If this fixes the issue I wouldn't recommened leaving the compatibility mode on, because it affects all software. Instead you can go to main UI > Settings > Virus protection > Exclude files from the scan and add terminal.exe to the "Objects" tab. Then you can turn compatiblity mode off again.

 

Ville

(F-Secure R&D)

 

3 REPLIES 3
F-Secure

Re: Why won't F-Secure let MetaTrader work

Hi @Lawrence

 

When our product blocks something because it's malware or suspicious, it will always show a flyer or dialog about it. In this scenario I couldn't see such flyer, so we are not actually blocking anything. The problem is on Metatrader side, usually caused by some integrity check or copy protection that reacts to DeepGuard.

 

You can check if this is the problem by going to our main UI > Settings > DeepGuard and enable "compatibility mode". If this fixes the issue I wouldn't recommened leaving the compatibility mode on, because it affects all software. Instead you can go to main UI > Settings > Virus protection > Exclude files from the scan and add terminal.exe to the "Objects" tab. Then you can turn compatiblity mode off again.

 

Ville

(F-Secure R&D)

 

Community Manager

Re: Why won't F-Secure let MetaTrader work

Hi Lawrence,

 

If you still need any further help, kindly open a support request with our team in order to get this checked further.

Has somebody helped you? Say thanks by giving likes. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Highlighted
Aspirant

Re: Why won't F-Secure let MetaTrader work

thx Ville. This worked!!