cancel
Showing results for 
Search instead for 
Did you mean: 

What are the system requirements for F-Secure Internet Security?

You need an active Internet connection to validate your subscription and receive updates. Javascript must be enabled in your browser settings to enable active block pages.

  • Supported platform: Windows 10, 8.1, 8, and 7 (SP1). ARM-based tablets are not supported.
  • Processor: Intel Pentium 4 or higher
  • Memory requirements: 1GB or more
  • Disk space: 1.2GB free disk space
  • Javascript must be enabled in the user's browser settings to enable active block pages.
Pricing & Product Info

For product info and pricing please go to the F-Secure SAFE product page

Version history
Revision #:
8 of 8
Last update:
‎09-01-2018 11:41 AM
Updated by: