Subscription Expired? But it should have 360 days to run!

Aspirant

Subscription Expired? But it should have 360 days to run!

Hi!  My wife and I installed F-Secure a couple of days ago after transferring from Virgin Media (don't get me started on the problems the wife had with that - if only we had seen the community messages first).

 

Anyway, her version is now running fine but mine has started telling me the subscription has expired! 

 

Have tried (and failed) to get hold of Tech Support.

 

What will fix this?

 

Thanks in advance

Tiny

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Re: Subscription Expired? But it should have 360 days to run!

Hi,

 

For SAFE, there is no need to enter any subscription key. It's all handled by the portal.

 

Could you please log into your MySafe portal?

It will tell you your expiry date.


Below that is a list of installed devices. If your device is not in that list, it does not use your Safe subscription.

 

Best regards,

Stephan

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
7 REPLIES 7
Advocate

Re: Subscription Expired? But it should have 360 days to run!

Sounds strange. I assume you've seen the instructions about the additional specific removal tool for VMS?

 

Something must be wrong with either the installation or the subscription and license. If you right-click the F-Secure icon in the systray at the bottom right corner of the desktop, and select "View my subscriptions". What expire date does it show?

The only thing I can think of is that you perhaps installed a 30-day trial by mistake. But that would only make sense if the message you received was a warning that the license will expire soon, not that it already has expired.

Give Kudos to say "thanks". Click "Accept as Solution" to inform others when your issue's been solved
Need more help? Submit a Support Request or chat / call F-Secure support
Superuser

Re: Subscription Expired? But it should have 360 days to run!

The other possibility is that maybe you've entered the subscription key incorrectly. Try entering it again, and see what happens.

Failing that, your best bet might be to send an email support request via the Contact Support link at the top of the page.
Highlighted
Community Manager

Re: Subscription Expired? But it should have 360 days to run!

Hi,

 

For SAFE, there is no need to enter any subscription key. It's all handled by the portal.

 

Could you please log into your MySafe portal?

It will tell you your expiry date.


Below that is a list of installed devices. If your device is not in that list, it does not use your Safe subscription.

 

Best regards,

Stephan

Has somebody helped you? Say thanks by giving kudos. Has your issue been solved? Mark the post using "Accept As Solution" button to let others know.
Aspirant

Re: Subscription Expired? But it should have 360 days to run!

no just followed the instructtions for the 1 year - but have found the key now thanks and will try entering that

 

thank you

Aspirant

Re: Subscription Expired? But it should have 360 days to run!

it didn't ever actually ask me to enter the key - hence i did not know it - but found now

 

thankyou

Aspirant

Re: Subscription Expired? But it should have 360 days to run!

Hi

 

yes i had my computer listed - i have tried to enter the key - will rebbot and hope fine!

 

thankyou

Superuser

Re: Subscription Expired? But it should have 360 days to run!

Sorry, the key might have been a red herring - see this post from Stephan:

 


@Stephan wrote:

Hi,

 

For SAFE, there is no need to enter any subscription key. It's all handled by the portal.

 

Could you please log into your MySafe portal?

It will tell you your expiry date.


Below that is a list of installed devices. If your device is not in that list, it does not use your Safe subscription.

 

Best regards,

Stephan